CVE-2024-8180: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
An issue has been discovered in GitLab CE/EE affecting all versions from 17.3 before 17.3.7, 17.4 before 17.4.4, and 17.5 before 17.5.2. Improper output encoding could lead to XSS if CSP is not enabled.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 17.3.7Fixed in 17.4.4Fixed in 17.5.2 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 17.3.7 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 17.4.4 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 17.5.2
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2024-8180?
CVE-2024-8180 is classified as a moderate severity vulnerability due to the potential for cross-site scripting (XSS) attacks.
How do I fix CVE-2024-8180?
To fix CVE-2024-8180, upgrade GitLab to version 17.3.7, 17.4.4, or 17.5.2 or later.
What versions of GitLab are affected by CVE-2024-8180?
CVE-2024-8180 affects all GitLab CE/EE versions from 17.3.0 before 17.3.7, 17.4.0 before 17.4.4, and 17.5.0 before 17.5.2.
What type of vulnerability is CVE-2024-8180?
CVE-2024-8180 is an improper output encoding vulnerability that can lead to cross-site scripting (XSS) if content security policy (CSP) is not enabled.
Is enabling CSP a solution for CVE-2024-8180?
Yes, enabling content security policy (CSP) can help mitigate the risks associated with CVE-2024-8180.