CVE-2024-8186: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
An issue has been discovered in GitLab CE/EE affecting all versions from 16.6 before 17.7.6, 17.8 before 17.8.4, and 17.9 before 17.9.1. An attacker could inject HMTL into the child item search potentially leading to XSS in certain situations.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 17.7.6Fixed in 17.8.4Fixed in 17.9.1 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 17.7.6 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 17.8.4 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 17.9.1
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2024-8186?
CVE-2024-8186 has a moderate severity level due to its potential for cross-site scripting (XSS) attacks.
How do I fix CVE-2024-8186?
To fix CVE-2024-8186, upgrade to GitLab versions 17.7.6, 17.8.4, or 17.9.1 or later.
What software versions are affected by CVE-2024-8186?
CVE-2024-8186 affects GitLab CE and EE versions from 16.6 up to but not including 17.7.6, 17.8 up to but not including 17.8.4, and 17.9 up to but not including 17.9.1.
What type of vulnerability is CVE-2024-8186?
CVE-2024-8186 is a cross-site scripting (XSS) vulnerability allowing HTML injection in child item searches.
Can CVE-2024-8186 be exploited remotely?
Yes, CVE-2024-8186 can potentially be exploited remotely if the conditions are met for the XSS injection.