CVE-2024-8193: High Heap buffer overflow in Skia
Heap buffer overflow in Skia in Google Chrome prior to 128.0.6613.113 allowed a remote attacker who had compromised the renderer process to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.73-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.73-1~deb13u1Fixed in 156.0.8078.47-1Fixed in 156.0.8078.73-1 - Upgrade
Upgrade
debian/webkit2gtkto a version that resolves this vulnerability.Fixed in 2.54.0-1~deb13u3Fixed in 2.54.2-2 - Upgrade
Upgrade
debian/wpewebkitto a version that resolves this vulnerability.Fixed in 2.54.2-1
Event History
Parent advisories
This vulnerability appears in the following advisories.
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2024-8193?
The severity of CVE-2024-8193 is classified as High.
How do I fix CVE-2024-8193?
To fix CVE-2024-8193, you should update Google Chrome to version 128.0.6613.113 or later.
What causes CVE-2024-8193?
CVE-2024-8193 is caused by a heap buffer overflow in the Skia graphics library used in Google Chrome.
Who can exploit CVE-2024-8193?
A remote attacker who has compromised the renderer process can exploit CVE-2024-8193 via a crafted HTML page.
What happens if CVE-2024-8193 is exploited?
Exploitation of CVE-2024-8193 can potentially lead to heap corruption on the affected system.