CVE-2024-8250: Expired Pointer Dereference in Wireshark
NTLMSSP dissector crash in Wireshark 4.2.0 to 4.0.6 and 4.0.0 to 4.0.16 allows denial of service via packet injection or crafted capture file
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/wiresharkto a version that resolves this vulnerability.Fixed in 4.0.17-0+deb12u1 - Upgrade
Upgrade
debian/wiresharkto a version that resolves this vulnerability.Fixed in 4.4.0-1 - Upgrade
Upgrade
debian/wiresharkto a version that resolves this vulnerability.Fixed in 4.0.17-0+deb12u3Fixed in 4.4.18-0+deb13u1Fixed in 4.4.19-0+deb13u1Fixed in 4.6.9-1 - Upgrade
Upgrade
Wiresharkto a version that resolves this vulnerability.Fixed in 4.2.7
Event History
Frequently Asked Questions
What is the severity of CVE-2024-8250?
CVE-2024-8250 is classified as a denial of service vulnerability.
How do I fix CVE-2024-8250?
To fix CVE-2024-8250, upgrade Wireshark to version 4.0.17 or 4.2.7 or later.
What versions of Wireshark are affected by CVE-2024-8250?
CVE-2024-8250 affects Wireshark versions from 4.0.0 to 4.0.16 and 4.2.0 to 4.2.6.
What exploitation methods are associated with CVE-2024-8250?
CVE-2024-8250 can be exploited through packet injection or by using a crafted capture file.
What are the potential impacts of CVE-2024-8250?
Exploiting CVE-2024-8250 can lead to a crash of the Wireshark application, resulting in denial of service.