CVE-2024-8925: Erroneous parsing of multipart form data
Erroneous parsing of multipart form data
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
PHPto a version that resolves this vulnerability.Fixed in 8.3.12 - Upgrade
Upgrade
debian/php7.4to a version that resolves this vulnerability.Fixed in 7.4.33-1+deb11u8 - Upgrade
Upgrade
debian/php8.2to a version that resolves this vulnerability.Fixed in 8.2.26-1~deb12u1Fixed in 8.2.28-1~deb12u1 - Upgrade
Upgrade
PHPto a version that resolves this vulnerability.Fixed in 8.1.30 - Upgrade
Upgrade
PHPto a version that resolves this vulnerability.Fixed in 8.2.24
Event History
Frequently Asked Questions
What is the severity of CVE-2024-8925?
CVE-2024-8925 has a severity rating that indicates a moderate risk due to data integrity violations.
How do I fix CVE-2024-8925?
To fix CVE-2024-8925, upgrade PHP to versions 8.1.30, 8.2.26 or later, or 8.3.12.
What is the impact of CVE-2024-8925?
The impact of CVE-2024-8925 is that improper parsing of multipart form data may result in legitimate data not being processed.
Which versions of PHP are affected by CVE-2024-8925?
CVE-2024-8925 affects PHP versions 8.1.0 to 8.1.29, 8.2.0 to 8.2.24, and pre-8.3.12 versions.
Is there a workaround for CVE-2024-8925?
There are no specific workarounds for CVE-2024-8925; upgrading to a patched version is necessary.