CVE-2024-9780: Missing Initialization of a Variable in Wireshark
ITS dissector crash in Wireshark 4.4.0 allows denial of service via packet injection or crafted capture file
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/wiresharkto a version that resolves this vulnerability.Fixed in 4.4.1-1 - Upgrade
Upgrade
debian/wiresharkto a version that resolves this vulnerability.Fixed in 4.0.17-0+deb12u3Fixed in 4.4.18-0+deb13u1Fixed in 4.4.19-0+deb13u1Fixed in 4.6.9-1 - Upgrade
Upgrade
Wiresharkto a version that resolves this vulnerability.Fixed in 4.4.1
Event History
Frequently Asked Questions
What is the severity of CVE-2024-9780?
CVE-2024-9780 is categorized as a denial of service vulnerability due to a crash in the ITS dissector.
How do I fix CVE-2024-9780?
To fix CVE-2024-9780, upgrade to Wireshark version 4.4.1 or later.
What causes the CVE-2024-9780 vulnerability?
CVE-2024-9780 is caused by a crash in Wireshark's ITS dissector when processing crafted packets or capture files.
Can CVE-2024-9780 be exploited remotely?
Yes, CVE-2024-9780 can be exploited remotely through packet injection or by using crafted capture files.
Which versions of Wireshark are affected by CVE-2024-9780?
CVE-2024-9780 specifically affects Wireshark version 4.4.0.