CVE-2024-9781: Improper Handling of Missing Values in Wireshark
AppleTalk and RELOAD Framing dissector crash in Wireshark 4.4.0 and 4.2.0 to 4.2.7 allows denial of service via packet injection or crafted capture file
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/wiresharkto a version that resolves this vulnerability.Fixed in 4.0.17-0+deb12u2 - Upgrade
Upgrade
debian/wiresharkto a version that resolves this vulnerability.Fixed in 4.4.1-1 - Upgrade
Upgrade
debian/wiresharkto a version that resolves this vulnerability.Fixed in 4.0.17-0+deb12u3Fixed in 4.4.18-0+deb13u1Fixed in 4.4.19-0+deb13u1Fixed in 4.6.9-1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 4.4.1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 4.2.8
Event History
Frequently Asked Questions
What is the severity of CVE-2024-9781?
CVE-2024-9781 is considered a high-severity vulnerability as it allows for denial of service due to a crash in the AppleTalk and RELOAD Framing dissector.
How do I fix CVE-2024-9781?
To fix CVE-2024-9781, upgrade Wireshark to version 4.2.8 or later, or to version 4.4.1 or later.
What versions of Wireshark are affected by CVE-2024-9781?
Wireshark versions 4.2.0 to 4.2.7 and version 4.4.0 are affected by CVE-2024-9781.
What kind of attack does CVE-2024-9781 facilitate?
CVE-2024-9781 allows an attacker to perform a denial of service attack via packet injection or crafted capture files.
Who reported CVE-2024-9781?
CVE-2024-9781 was reported by researchers following the identification of a vulnerability in specific disssector functionality within Wireshark.