CVE-2024-9859: High severity Google Chrome vulnerability
Type confusion in WebAssembly in Google Chrome prior to 126.0.6478.126 allowed a remote attacker to execute arbitrary code via a crafted HTML page. (Chromium security severity: High)
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 126.0.6478.126-1~deb12u1 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 126.0.6478.126-1 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.73-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.73-1~deb13u1Fixed in 156.0.8078.47-1Fixed in 156.0.8078.79-1
Event History
Frequently Asked Questions
What is the severity of CVE-2024-9859?
The severity of CVE-2024-9859 is categorized as High.
How do I fix CVE-2024-9859?
To fix CVE-2024-9859, update Google Chrome to version 126.0.6478.126 or later.
What type of vulnerability is CVE-2024-9859?
CVE-2024-9859 is a type confusion vulnerability in WebAssembly within Google Chrome.
What kind of attack can CVE-2024-9859 enable?
CVE-2024-9859 can allow a remote attacker to execute arbitrary code via a crafted HTML page.
Which versions of Google Chrome are affected by CVE-2024-9859?
Google Chrome versions prior to 126.0.6478.126 are affected by CVE-2024-9859.