CVE-2025-0510: Address of e-mail sender can be spoofed by malicious email
Thunderbird displayed an incorrect sender address if the From field of an email used the invalid group name syntax that is described in CVE-2024-49040. This vulnerability was fixed in Thunderbird 128.7 and Thunderbird 135.
Other sources
Thunderbird displayed an incorrect sender address if the From field of an email used the invalid group name syntax that is described in CVE-2024-49040. This vulnerability affects Thunderbird < 128.7 and Thunderbird < 135.
— Red Hat
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Thunderbirdto a version that resolves this vulnerability.Fixed in 135 - Upgrade
Upgrade
ubuntu/thunderbirdto a version that resolves this vulnerability.Fixed in 1:128.12.0+build1-0ubuntu0.22.04.1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 128.7 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:140.12.0esr-1~deb12u1Fixed in 1:153.6.0esr-1~deb12u1Fixed in 1:140.12.0esr-1~deb13u1Fixed in 1:153.5.1esr-1~deb13u2Fixed in 1:153.5.0esr-1Fixed in 1:153.6.0esr-1 - Upgrade
Upgrade
Thunderbirdto a version that resolves this vulnerability.Fixed in 128.7
Event History
Parent advisories
This vulnerability appears in the following advisories.
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2025-0510?
CVE-2025-0510 is classified as a moderate severity vulnerability.
How do I fix CVE-2025-0510?
To fix CVE-2025-0510, update Thunderbird to version 135 or 128.7 or later.
What issue does CVE-2025-0510 cause in Thunderbird?
CVE-2025-0510 causes Thunderbird to display an incorrect sender address when an email's From field uses invalid group name syntax.
Which versions of Thunderbird are affected by CVE-2025-0510?
CVE-2025-0510 affects Thunderbird versions below 135 and 128.7.
Is there a workaround for CVE-2025-0510?
There are no known workarounds for CVE-2025-0510; the best approach is to update your software.