CVE-2025-0678: Grub2: squash4: integer overflow may lead to heap based out-of-bounds write when reading data

Published Feb 17, 2025
·
Updated

A flaw was found in grub2. When reading data from a squash4 filesystem, grub's squash4 fs module uses user-controlled parameters from the filesystem geometry to determine the internal buffer size, however, it improperly checks for integer overflows. A maliciously crafted filesystem may lead some of those buffer size calculations to overflow, causing it to perform a grubmalloc() operation with a smaller size than expected. As a result, the directread() will perform a heap based out-of-bounds write during data reading. This flaw may be leveraged to corrupt grub's internal critical data and may result in arbitrary code execution, by-passing secure boot protections.

Other sources

Grub2: squash4: integer overflow may lead to heap based out-of-bounds write when reading data

— Microsoft

When reading data from a squash4 filesystem, grub's squash4 fs module uses user-controlled parameters from the filesystem geometry to determine the internal buffers size, however it misses to properly check for integer overflows. A maliciously crafted filesystem may lead some of those buffer size calculation to overflow, causing it to perform a grubmalloc() operation with a smaller size than expected. As a result the directread() will perform a heap based out-of-bounds write during data reading. This flaw may be leveraged to corrupt grub's internal critical data and may result in arbitrary code execution by-passing secure boot protections.

— Red Hat

Affected Software

14 affected componentsFixes available
GNU GRUB
Microsoft cbl2 grub2 2.06-14<2.06-15
2.06-15
Microsoft azl3 grub2 2.06-25<2.06-25
2.06-25
Microsoft cbl2 grub2 2.06-15<2.06-15
2.06-15
Microsoft azl3 grub2 2.06-24<2.06-25
2.06-25
GNU GRUB2<=2.12
redhat OpenShift Container Platform=4.0
redhat Enterprise Linux=7.0
redhat Enterprise Linux=8.0
redhat Enterprise Linux=9.0
debian/grub2<2.06-13+deb12u2
2.06-13+deb12u2
debian/grub2<2.12-6
2.12-6
debian/grub2<2.12-6
2.12-6
debian/grub2<=2.06-13+deb12u1
2.06-13+deb12u22.12-9+deb13u22.14-42.14-5

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 2.06-15
  2. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 2.06-25
  3. Upgrade

    Upgrade debian/grub2 to a version that resolves this vulnerability.

    Fixed in 2.06-13+deb12u2
  4. Upgrade

    Upgrade debian/grub2 to a version that resolves this vulnerability.

    Fixed in 2.12-6
  5. Upgrade

    Upgrade debian/grub2 to a version that resolves this vulnerability.

    Fixed in 2.06-13+deb12u2Fixed in 2.12-9+deb13u2Fixed in 2.14-4Fixed in 2.14-5

Event History

Feb 17, 2025
Data Sourced
via Red Hat·03:12 PM
DescriptionSeverityAffected Software
Mar 3, 2025
CVE Published
via MITRE·05:05 PM
Data Sourced
via MITRE·05:05 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·05:15 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·05:15 PM
DescriptionSeverityAffected Software
Mar 31, 2025
News Published
via BleepingComputer·07:56 PM
Sep 4, 2025
Data Sourced
via Microsoft·02:43 PM
DescriptionSeverityWeaknessAffected Software

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2025-0678?

CVE-2025-0678 has been classified as a moderate severity vulnerability.

2

How do I fix CVE-2025-0678?

To mitigate CVE-2025-0678, it is recommended to update to the latest version of the GNU GRUB that addresses this flaw.

3

What systems are impacted by CVE-2025-0678?

CVE-2025-0678 affects the GNU GRUB bootloader, specifically on systems utilizing the squash4 filesystem.

4

What kind of attack does CVE-2025-0678 facilitate?

CVE-2025-0678 can potentially allow an attacker to exploit integer overflow vulnerabilities when reading from a maliciously crafted squash4 filesystem.

5

Is there a workaround for CVE-2025-0678?

Currently, there is no specified workaround for CVE-2025-0678, so applying the patch is essential.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203