CVE-2025-1094: PostgreSQL quoting APIs miss neutralizing quoting syntax in text that fails encoding validation

Published Feb 13, 2025
·
Updated

Improper neutralization of quoting syntax in PostgreSQL libpq functions PQescapeLiteral(), PQescapeIdentifier(), PQescapeString(), and PQescapeStringConn() allows a database input provider to achieve SQL injection in certain usage patterns. Specifically, SQL injection requires the application to use the function result to construct input to psql, the PostgreSQL interactive terminal. Similarly, improper neutralization of quoting syntax in PostgreSQL command line utility programs allows a source of command line arguments to achieve SQL injection when clientencoding is BIG5 and serverencoding is one of EUCTW or MULEINTERNAL. Versions before PostgreSQL 17.3, 16.7, 15.11, 14.16, and 13.19 are affected.

Other sources

PostgreSQL quoting APIs miss neutralizing quoting syntax in text that fails encoding validation

— Microsoft

This CVE was automatically created from a reference found in an email or other text. If you are reading this, then this CVE entry is probably erroneous, since this text should be replaced by the official CVE description automatically.

— Launchpad

Affected Software

30 affected componentsFixes available
PostgreSQL postgresql<17.3, <16.7, <15.11, <14.16, <13.19
F5 BIG-IP Next Central Manager
Microsoft azl3 postgresql 16.5-2<16.7-1
16.7-1
Microsoft cbl2 postgresql 14.14-1<14.16-1
14.16-1
Microsoft cbl2 postgresql 14.16-1<14.16-1
14.16-1
Microsoft azl3 postgresql 16.7-1<16.7-1
16.7-1
alpine/postgresql13<13.20-r0
13.20-r0
alpine/postgresql13<13.20-r0
13.20-r0
alpine/postgresql14<14.17-r0
14.17-r0
alpine/postgresql14<14.17-r0
14.17-r0
alpine/postgresql14<14.17-r0
14.17-r0
alpine/postgresql15<15.11-r0
15.11-r0
alpine/postgresql15<15.11-r0
15.11-r0
alpine/postgresql15<15.11-r0
15.11-r0
alpine/postgresql15<15.11-r0
15.11-r0
alpine/postgresql15<15.11-r0
15.11-r0
alpine/postgresql16<16.8-r0
16.8-r0
alpine/postgresql16<16.8-r0
16.8-r0
alpine/postgresql16<16.8-r0
16.8-r0
alpine/postgresql16<16.8-r0
16.8-r0
alpine/postgresql16<16.8-r0
16.8-r0
alpine/postgresql16<16.8-r0
16.8-r0
alpine/postgresql17<17.4-r0
17.4-r0
alpine/postgresql17<17.4-r0
17.4-r0
alpine/postgresql17<17.4-r0
17.4-r0
alpine/postgresql17<17.4-r0
17.4-r0
debian/postgresql-15<15.11-0+deb12u1
15.11-0+deb12u1
debian/postgresql-17<17.3-1
17.3-1
debian/postgresql-15
15.18-0+deb12u115.19-0+deb12u1
debian/postgresql-17
17.11-0+deb13u1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 16.7-1
  2. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 14.16-1
  3. Upgrade

    Upgrade alpine/postgresql13 to a version that resolves this vulnerability.

    Fixed in 13.20-r0
  4. Upgrade

    Upgrade alpine/postgresql14 to a version that resolves this vulnerability.

    Fixed in 14.17-r0
  5. Upgrade

    Upgrade alpine/postgresql15 to a version that resolves this vulnerability.

    Fixed in 15.11-r0
  6. Upgrade

    Upgrade alpine/postgresql16 to a version that resolves this vulnerability.

    Fixed in 16.8-r0
  7. Upgrade

    Upgrade alpine/postgresql17 to a version that resolves this vulnerability.

    Fixed in 17.4-r0
  8. Upgrade

    Upgrade debian/postgresql-15 to a version that resolves this vulnerability.

    Fixed in 15.11-0+deb12u1
  9. Upgrade

    Upgrade debian/postgresql-17 to a version that resolves this vulnerability.

    Fixed in 17.3-1
  10. Upgrade

    Upgrade debian/postgresql-15 to a version that resolves this vulnerability.

    Fixed in 15.18-0+deb12u1Fixed in 15.19-0+deb12u1
  11. Upgrade

    Upgrade debian/postgresql-17 to a version that resolves this vulnerability.

    Fixed in 17.11-0+deb13u1

Event History

Feb 13, 2025
CVE Published
via MITRE·01:00 PM
Data Sourced
via MITRE·01:00 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·01:15 PM
DescriptionSeverityWeakness
Data Sourced
via OSV·01:15 PM
DescriptionSeverityAffected Software
Data Sourced
via Red Hat·02:01 PM
DescriptionSeverityAffected Software
Feb 14, 2025
News Published
via BleepingComputer·02:15 PM
News Published
via The Register·02:19 PM
Feb 20, 2025
Data Sourced
via Microsoft·08:00 AM
DescriptionSeverityWeakness
Data Sourced
via Microsoft·08:00 AM
Affected Software
Feb 27, 2025
Exploit Published
via GitHub·11:08 AM
Apr 7, 2025
Advisory Published
via F5·05:51 PM
Jun 18, 2025
News Published
via BleepingComputer·10:10 AM

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2025-1094?

CVE-2025-1094 is classified as a high-severity vulnerability due to its potential for SQL injection exploitation.

2

How do I fix CVE-2025-1094?

To mitigate CVE-2025-1094, it is recommended to upgrade PostgreSQL to versions 17.3, 16.7, 15.11, 14.16, or 13.19 or later.

3

What types of functions are affected by CVE-2025-1094?

CVE-2025-1094 affects the PQescapeLiteral(), PQescapeIdentifier(), PQescapeString(), and PQescapeStringConn() functions in PostgreSQL.

4

Who is affected by CVE-2025-1094?

Users of PostgreSQL versions below 17.3, 16.7, 15.11, 14.16, and 13.19 are potentially affected by CVE-2025-1094.

5

What is SQL injection in the context of CVE-2025-1094?

In the context of CVE-2025-1094, SQL injection allows attackers to manipulate queries through improperly sanitized inputs in PostgreSQL libpq functions.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203