CVE-2025-11570: drupal-pattern-lab/unified-twig-extensions is vulnerable to XXS

Published Oct 10, 2025
·
Updated

drupal-pattern-lab/unified-twig-extensions is vulnerable to XXS

Other sources

Versions of the package drupal-pattern-lab/unified-twig-extensions from 0.0.0 are vulnerable to Cross-site Scripting (XSS) due to insufficient filtering of data.

Note: This is exploitable only if the code is executed outside of Drupal; the function is intended to be shared between Drupal and Pattern Lab.

The package drupal-pattern-lab/unified-twig-extensions is unmaintained, the fix for this issue exists in version 1.1.1 of drupal/unifiedtwigext, but is not published to the Composer PHP registry.

— GitHub

Affected Software

3 affected components
Drupal Pattern Lab Unified Twig Extensions>0.0.0
composer/drupal-pattern-lab/unified-twig-extensions<=0.1.0
composer/drupal-pattern-lab/unified-twig-extensions<=0.1.0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade drupal/unified_twig_ext to a version that resolves this vulnerability.

    Fixed in 1.1.1

Event History

Oct 10, 2025
CVE Published
via MITRE·05:00 AM
Data Sourced
via MITRE·05:00 AM
DescriptionSeverityWeakness
Data Sourced
via NVD·05:15 AM
DescriptionSeverityWeakness
Event
via NVD·05:15 AM
Advisory Published
via GitHub·06:30 AM
Data Sourced
via GitHub·06:30 AM
DescriptionWeaknessAffected Software
Data Sourced
via Packagist·06:30 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2025-11570?

CVE-2025-11570 has a moderate severity due to its potential to allow Cross-site Scripting (XSS) attacks.

2

How do I fix CVE-2025-11570?

To fix CVE-2025-11570, update the drupal-pattern-lab/unified-twig-extensions package to a version that is not vulnerable.

3

Which versions are affected by CVE-2025-11570?

CVE-2025-11570 affects versions of drupal-pattern-lab/unified-twig-extensions from 0.0.0.

4

Is the CVE-2025-11570 vulnerability exploitable in Drupal?

CVE-2025-11570 is exploitable only if the code is executed outside of Drupal.

5

What kind of vulnerability is CVE-2025-11570?

CVE-2025-11570 is a Cross-site Scripting (XSS) vulnerability due to insufficient data filtering.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203