CVE-2025-11794: Password hash and MFA secret returned in user email verification endpoint
Mattermost versions 10.11.x <= 10.11.3, 10.5.x <= 10.5.11, 10.12.x <= 10.12.0 fail to sanitize user data which allows system administrators to access password hashes and MFA secrets via the POST /api/v4/users/{userid}/email/verify/member endpoint
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
go/github.com/mattermost/mattermost/server/v8to a version that resolves this vulnerability.Fixed in 8.0.0-20250929212932-a41db04d2746 - Upgrade
Upgrade
go/github.com/mattermost/mattermost-serverto a version that resolves this vulnerability.Fixed in 10.12.1 - Upgrade
Upgrade
go/github.com/mattermost/mattermost-serverto a version that resolves this vulnerability.Fixed in 10.5.12 - Upgrade
Upgrade
go/github.com/mattermost/mattermost-serverto a version that resolves this vulnerability.Fixed in 10.11.4 - Upgrade
Upgrade
Mattermostto a version that resolves this vulnerability.Fixed in 11.0.0 - Upgrade
Upgrade
Mattermostto a version that resolves this vulnerability.Fixed in 10.11.4 - Upgrade
Upgrade
Mattermostto a version that resolves this vulnerability.Fixed in 10.5.12 - Upgrade
Upgrade
Mattermostto a version that resolves this vulnerability.Fixed in 10.12.1
Event History
Frequently Asked Questions
What is the severity of CVE-2025-11794?
CVE-2025-11794 is classified as a critical vulnerability due to the potential exposure of sensitive user data.
How do I fix CVE-2025-11794?
To fix CVE-2025-11794, you should update Mattermost to the latest version that addresses this vulnerability.
What versions are affected by CVE-2025-11794?
CVE-2025-11794 affects Mattermost versions 10.11.x up to 10.11.3, 10.5.x up to 10.5.11, and 10.12.x up to 10.12.0.
What data can be accessed due to CVE-2025-11794?
Due to CVE-2025-11794, system administrators can access sensitive data such as password hashes and multi-factor authentication secrets.
Is CVE-2025-11794 being actively exploited?
As of now, there are no public reports of active exploitation of CVE-2025-11794, but it is considered highly critical.