CVE-2025-12555: Incorrect Authorization in GitLab

Published Mar 11, 2026
·
Updated

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 15.1 before 18.7.6, 18.8 before 18.8.6, and 18.9 before 18.9.2 that, under certain conditions, could have allowed an authenticated user to access previous pipeline job information on projects with repository and CI/CD disabled due to improper authorization checks.

Other sources

GitLab has remediated an issue that, under certain conditions, could have allowed an authenticated user to access previous pipeline job information on projects with repository and CI/CD disabled due to improper authorization checks.

— GitLab

Affected Software

7 affected componentsFixes available
GitLab GitLab>=15.1<18.7.6, >=18.8<18.8.6, >=18.9<18.9.2
18.7.618.8.618.9.2
GitLab GitLab>=15.1.0<18.7.6
GitLab GitLab>=15.1.0<18.7.6
GitLab GitLab>=18.8.0<18.8.6
GitLab GitLab>=18.8.0<18.8.6
GitLab GitLab>=18.9.0<18.9.2
GitLab GitLab>=18.9.0<18.9.2

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 18.7.6Fixed in 18.8.6Fixed in 18.9.2
  2. Upgrade

    Upgrade GitLab CE/EE to a version that resolves this vulnerability.

    Fixed in 18.7.6
  3. Upgrade

    Upgrade GitLab CE/EE to a version that resolves this vulnerability.

    Fixed in 18.8.6
  4. Upgrade

    Upgrade GitLab CE/EE to a version that resolves this vulnerability.

    Fixed in 18.9.2

Event History

Mar 11, 2026
CVE Published
via MITRE·04:07 PM
Data Sourced
via MITRE·04:07 PM
RemedyDescriptionSeverityWeakness
Data Sourced
via OSV·04:07 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·05:16 PM
DescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2025-12555?

CVE-2025-12555 has been rated as a high severity vulnerability due to potential unauthorized access to sensitive pipeline job information.

2

How do I fix CVE-2025-12555?

To remediate CVE-2025-12555, you should upgrade to GitLab versions 18.7.6, 18.8.6, or 18.9.2 depending on your current version.

3

Who is affected by CVE-2025-12555?

CVE-2025-12555 affects all GitLab Community Edition and Enterprise Edition versions from 15.1 to before the specified patched versions.

4

What type of vulnerability is CVE-2025-12555?

CVE-2025-12555 is classified as an incorrect authorization vulnerability that could allow users to access restricted information.

5

What versions are vulnerable to CVE-2025-12555?

Versions from GitLab 15.1 to prior to 18.7.6, 18.8 to prior to 18.8.6, and 18.9 to prior to 18.9.2 are considered vulnerable.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203