CVE-2025-13081: Drupal core allows Object Injection

Published Nov 18, 2025
·
Updated

Drupal core allows Object Injection

Affected Software

13 affected componentsFixes available
Drupal Drupal Core>=8.0.0, <10.4.9, >=10.5.0, <10.5.6, >=11.0.0, <11.1.9, >=11.2.0, <11.2.8
composer/drupal/core>=11.2.0<11.2.8
11.2.8
composer/drupal/core>=11.0.0<11.1.9
11.1.9
composer/drupal/core>=10.5.0<10.5.6
10.5.6
composer/drupal/core>=8.0.0<10.4.9
10.4.9
Drupal Drupal>=8.0.0<10.4.9
Drupal Drupal>=10.5.0<10.5.6
Drupal Drupal>=11.0.0<11.1.9
Drupal Drupal>=11.2.0<11.2.8
composer/drupal/core>=11.2.0, <11.2.8
11.2.8
composer/drupal/core>=11.0.0, <11.1.9
11.1.9
composer/drupal/core>=10.5.0, <10.5.6
10.5.6
composer/drupal/core>=8.0.0, <10.4.9
10.4.9

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/drupal/core to a version that resolves this vulnerability.

    Fixed in 11.2.8
  2. Upgrade

    Upgrade composer/drupal/core to a version that resolves this vulnerability.

    Fixed in 11.1.9
  3. Upgrade

    Upgrade composer/drupal/core to a version that resolves this vulnerability.

    Fixed in 10.5.6
  4. Upgrade

    Upgrade composer/drupal/core to a version that resolves this vulnerability.

    Fixed in 10.4.9

Event History

Nov 18, 2025
CVE Published
via MITRE·04:54 PM
Data Sourced
via MITRE·04:54 PM
DescriptionWeakness
Data Sourced
via NVD·05:15 PM
DescriptionSeverityWeaknessAffected Software
Advisory Published
via GitHub·06:32 PM
Data Sourced
via GitHub·06:32 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·06:32 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2025-13081?

CVE-2025-13081 is considered a critical vulnerability due to its potential for object injection attacks in Drupal core.

2

How do I fix CVE-2025-13081?

To mitigate CVE-2025-13081, update your Drupal core to versions 10.5.6 or later, or to 11.1.9 or later.

3

Which versions of Drupal are affected by CVE-2025-13081?

CVE-2025-13081 affects Drupal core versions from 8.0.0 before 10.4.9, 10.5.0 before 10.5.6, and 11.0.0 before 11.1.9, among others.

4

What kind of attack does CVE-2025-13081 allow?

CVE-2025-13081 allows for improperly controlled modification of dynamically-determined object attributes, leading to object injection.

5

Is CVE-2025-13081 a known issue in Drupal?

Yes, CVE-2025-13081 is a recognized vulnerability and has been documented in Drupal's security advisory.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203