CVE-2025-22045: x86/mm: Fix flush_tlb_range() when used for zapping normal PMDs

Published Apr 16, 2025
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

x86/mm: Fix flushtlbrange() when used for zapping normal PMDs

On the following path, flushtlbrange() can be used for zapping normal PMD entries (PMD entries that point to page tables) together with the PTE entries in the pointed-to page table:

collapseptemappedthp pmdpcollapseflush flushtlbrange

The arm64 version of flushtlbrange() has a comment describing that it can be used for page table removal, and does not use any last-level invalidation optimizations. Fix the X86 version by making it behave the same way.

Currently, X86 only uses this information for the following two purposes, which I think means the issue doesn't have much impact:

- In nativeflushtlbmulti() for checking if lazy TLB CPUs need to be IPI'd to avoid issues with speculative page table walks. - In Hyper-V TLB paravirtualization, again for lazy TLB stuff.

The patch "x86/mm: only invalidate final translations with INVLPGB" which is currently under review (see <https://lore.kernel.org/all/20241230175550.4046587-13-riel@surriel.com/>) would probably be making the impact of this a lot worse.

Affected Software

20 affected componentsFixes available
Linux Linux kernel
Microsoft azl3 kernel 6.6.85.1-4
Microsoft azl3 kernel 6.6.92.2-1
Linux Linux kernel>=4.20<5.4.292
Linux Linux kernel>=5.5<5.10.236
Linux Linux kernel>=5.11<5.15.180
Linux Linux kernel>=5.16<6.1.134
Linux Linux kernel>=6.2<6.6.87
Linux Linux kernel>=6.7<6.12.23
Linux Linux kernel>=6.13<6.13.11
Linux Linux kernel>=6.14<6.14.2
linux/kernel>=4.20.0<5.4.292
5.4.292
linux/kernel>=5.5.0<5.10.236
5.10.236
linux/kernel>=5.11.0<5.15.180
5.15.180
linux/kernel>=5.16.0<6.1.134
6.1.134
linux/kernel>=6.2.0<6.6.87
6.6.87
linux/kernel>=6.7.0<6.12.23
6.12.23
linux/kernel>=6.13.0<6.13.11
6.13.11
linux/kernel>=6.14.0<6.14.2
6.14.2
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 5.4.292
  2. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 5.10.236
  3. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 5.15.180
  4. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 6.1.134
  5. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 6.6.87
  6. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 6.12.23
  7. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 6.13.11
  8. Upgrade

    Upgrade linux/Kernel to a version that resolves this vulnerability.

    Fixed in 6.14.2
  9. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1

Event History

Apr 16, 2025
CVE Published
via MITRE·02:12 PM
Data Sourced
via MITRE·02:12 PM
DescriptionSeverity
Data Sourced
via OSV·02:12 PM
DescriptionSeverityAffected Software
Data Sourced
via NVD·03:15 PM
RemedyDescriptionSeverityAffected Software
Jul 11, 2025
Data Sourced
via Microsoft·07:00 AM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2025-22045?

The severity of CVE-2025-22045 is classified as medium due to its potential impact on system stability.

2

How do I fix CVE-2025-22045?

To fix CVE-2025-22045, update the Linux kernel to a version that incorporates the patch provided in the security advisory.

3

What versions of the Linux kernel are affected by CVE-2025-22045?

CVE-2025-22045 affects multiple versions of the Linux kernel ranging from 4.20 to 6.14.2.

4

Can CVE-2025-22045 be exploited remotely?

CVE-2025-22045 is not considered to be remotely exploitable, as it primarily impacts local privilege escalation.

5

Is there a workaround for CVE-2025-22045?

There are no known workarounds for CVE-2025-22045, so applying the necessary updates is recommended.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203