CVE-2025-23047: Cilium vulnerable to information leakage via insecure default Hubble UI CORS header

Published Jan 22, 2025
·
Updated

Impact

For users who deploy Hubble UI using either Cilium CLI or via the Cilium Helm chart, an insecure default Access-Control-Allow-Origin header value could lead to sensitive data exposure. A user with access to a Hubble UI instance affected by this issue could leak configuration details about the Kubernetes cluster which Hubble UI is monitoring, including node names, IP addresses, and other metadata about workloads and the cluster networking configuration. In order for this vulnerability to be exploited, a victim would have to first visit a malicious page.

Patches

This issue was patched in https://github.com/cilium/cilium/commit/a3489f190ba6e87b5336ee685fb6c80b1270d06d

This issue affects:

- Cilium between v1.14.0 and v1.14.18 inclusive - Cilium between v1.15.0 and v1.15.12 inclusive - Cilium between v1.16.0 and v1.16.5 inclusive

This issue is patched in:

- Cilium v1.14.19 - Cilium v1.15.13 - Cilium v1.16.6

Workarounds

Users who deploy Hubble UI using the Cilium Helm chart directly can remove the CORS headers from the Helm template as shown in the patch.

Acknowledgements

The Cilium community has worked together with members of Isovalent to prepare these mitigations. Special thanks to @ciffelia for reporting this issue and to @geakstr for the fix.

For more information If you have any questions or comments about this advisory, please reach out on Slack.

If you think you have found a vulnerability affecting Cilium, we strongly encourage you to report it to our security mailing list at security@cilium.io. This is a private mailing list for the Cilium security team, and your report will be treated as top priority.

Other sources

Cilium is a networking, observability, and security solution with an eBPF-based dataplane. An insecure default Access-Control-Allow-Origin header value could lead to sensitive data exposure for users of Cilium versions 1.14.0 through 1.14.7, 1.15.0 through 1.15.11, and 1.16.0 through 1.16.4 who deploy Hubble UI using either Cilium CLI or via the Cilium Helm chart. A user with access to a Hubble UI instance affected by this issue could leak configuration details about the Kubernetes cluster which Hubble UI is monitoring, including node names, IP addresses, and other metadata about workloads and the cluster networking configuration. In order for this vulnerability to be exploited, a victim would have to first visit a malicious page. This issue is fixed in Cilium v1.14.18, v1.15.12, and v1.16.5. As a workaround, users who deploy Hubble UI using the Cilium Helm chart directly can remove the CORS headers from the Helm template as shown in the patch from commit a3489f190ba6e87b5336ee685fb6c80b1270d06d.

— NVD

Affected Software

7 affected componentsFixes available
go/github.com/cilium/cilium>=1.16.0<1.16.6
1.16.6
go/github.com/cilium/cilium>=1.15.0<1.15.13
1.15.13
go/github.com/cilium/cilium>=1.14.0<1.14.19
1.14.19
Cilium Cilium>=1.14.0<=1.14.7, >=1.15.0<=1.15.11, >=1.16.0<=1.16.4
Cilium Cilium>=1.14.0<1.14.19
Cilium Cilium>=1.15.0<1.15.13
Cilium Cilium>=1.16.0<1.16.6

Event History

Jan 22, 2025
CVE Published
via MITRE·05:20 PM
Data Sourced
via MITRE·05:20 PM
DescriptionSeverityWeakness
Advisory Published
via GitHub·06:09 PM
Data Sourced
via NVD·06:15 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·06:15 PM
RemedyAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2025-23047?

CVE-2025-23047 is considered a high-severity vulnerability due to its potential for sensitive data exposure.

2

How do I fix CVE-2025-23047?

To remediate CVE-2025-23047, upgrade to Cilium versions 1.14.19, 1.15.13, or 1.16.6.

3

Who is affected by CVE-2025-23047?

Users deploying Hubble UI with Cilium CLI or the Cilium Helm chart in affected versions are at risk from CVE-2025-23047.

4

What data is at risk due to CVE-2025-23047?

CVE-2025-23047 could lead to the exposure of sensitive configuration data accessible through Hubble UI.

5

Which Cilium versions are vulnerable to CVE-2025-23047?

Cilium versions from 1.14.0 to 1.14.7, 1.15.0 to 1.15.11, and 1.16.0 to 1.16.4 are vulnerable to CVE-2025-23047.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203