CVE-2025-23085: GOAWAY HTTP/2 frames cause memory leak outside heap

Published Jan 21, 2025
·
Updated

A memory leak could occur when a remote peer abruptly closes the socket without sending a GOAWAY notification. Additionally, if an invalid header was detected by nghttp2, causing the connection to be terminated by the peer, the same leak was triggered. This flaw could lead to increased memory consumption and potential denial of service under certain conditions.

Affected Software

10 affected componentsFixes available
Node.js Node.js>=18.0.0<24.0.0
Microsoft azl3 nodejs 20.14.0-8<20.14.0-5
20.14.0-5
Microsoft azl3 nodejs 20.14.0-5<20.14.0-5
20.14.0-5
Microsoft cbl2 nodejs18 18.20.3-3<18.20.3-3
18.20.3-3
Microsoft cbl2 nodejs18 18.20.3-6<18.20.3-3
18.20.3-3
Node.js Node.js>=18.0.0<18.20.6, >=20.0.0<20.18.2, >=22.0.0<22.13.1, >=23.0.0<23.6.1
18.20.620.18.222.13.123.6.1
Node.js Node.js>=18.0.0<18.20.6
18.20.6
Node.js Node.js>=20.0.0<20.18.2
20.18.2
Node.js Node.js>=22.0.0<22.13.1
22.13.1
Node.js Node.js>=23.0.0<23.6.1
23.6.1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 20.14.0-5
  2. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 18.20.3-3
  3. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 18.20.6Fixed in 20.18.2Fixed in 22.13.1Fixed in 23.6.1
  4. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 18.20.6
  5. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 20.18.2
  6. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 22.13.1
  7. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 23.6.1

Event History

Jan 21, 2025
CVE Published
via Node.js·03:00 AM
Data Sourced
via Node.js·03:00 AM
DescriptionSeverityAffected Software
Jan 28, 2025
Data Sourced
via Red Hat·05:26 PM
DescriptionSeverityAffected Software
Feb 7, 2025
CVE Published
via MITRE·07:09 AM
Data Sourced
via MITRE·07:09 AM
DescriptionSeverity
Data Sourced
via NVD·07:15 AM
DescriptionSeverityWeakness
Feb 14, 2025
Data Sourced
via Microsoft·08:00 AM
DescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2025-23085?

CVE-2025-23085 has been classified with a severity that could lead to increased resource consumption due to a memory leak.

2

How do I fix CVE-2025-23085?

To mitigate CVE-2025-23085, it is recommended to update Node.js to the latest version beyond the vulnerable releases.

3

Which versions of Node.js are affected by CVE-2025-23085?

CVE-2025-23085 affects Node.js versions from 18.x to 23.x.

4

What causes the memory leak in CVE-2025-23085?

The memory leak in CVE-2025-23085 is caused when a remote peer abruptly closes the socket without a GOAWAY notification or if invalid headers are detected.

5

Is there a workaround for CVE-2025-23085?

Currently, the best approach for CVE-2025-23085 is to apply the security updates as there are no effective workarounds identified.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203