CVE-2025-23138: watch_queue: fix pipe accounting mismatch

Published Apr 16, 2025
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

watchqueue: fix pipe accounting mismatch

Currently, watchqueuesetsize() modifies the pipe buffers charged to user->pipebufs without updating the pipe->nraccounted on the pipe itself, due to the if (!pipehaswatchqueue()) test in piperesizering(). This means that when the pipe is ultimately freed, we decrement user->pipebufs by something other than what than we had charged to it, potentially leading to an underflow. This in turn can cause subsequent toomanypipebufferssoft() tests to fail with -EPERM.

To remedy this, explicitly account for the pipe usage in watchqueuesetsize() to match the number set via accountpipebuffers()

(It's unclear why watchqueuesetsize() does not update nraccounted; it may be due to intentional overprovisioning in watchqueuesetsize()?)

Affected Software

10 affected componentsFixes available
Linux Linux kernel
Linux Linux kernel>=5.10.210<5.10.236
Linux Linux kernel>=5.15.149<5.15.180
Linux Linux kernel>=6.1.76<6.1.134
Linux Linux kernel>=6.6.15<6.6.87
Linux Linux kernel>=6.7.3<6.12.23
Linux Linux kernel>=6.13<6.13.11
Linux Linux kernel>=6.14<6.14.2
Debian Debian Linux=11.0
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1

Event History

Apr 16, 2025
CVE Published
via MITRE·02:13 PM
Data Sourced
via MITRE·02:13 PM
Description
Data Sourced
via NVD·03:16 PM
RemedyDescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2025-23138?

CVE-2025-23138 is rated as a medium severity vulnerability affecting the Linux kernel.

2

How do I fix CVE-2025-23138?

To fix CVE-2025-23138, you should update your Linux kernel to the latest stable version provided by your distribution.

3

What are the impacts of CVE-2025-23138 on system performance?

CVE-2025-23138 can lead to incorrect resource accounting for pipe buffers, potentially affecting system performance under high loads.

4

Which versions of the Linux kernel are affected by CVE-2025-23138?

CVE-2025-23138 impacts various versions of the Linux kernel prior to the patches that address this specific vulnerability.

5

Is CVE-2025-23138 actively being exploited in the wild?

As of now, there is no indication that CVE-2025-23138 is being actively exploited in the wild, but it is advisable to apply patches promptly.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203