CVE-2025-23167: Improper HTTP header block termination in llhttp

Published May 14, 2025
·
Updated

A flaw in Node.js 20's HTTP parser allows improper termination of HTTP/1 headers using \r\n\rX instead of the required \r\n\r\n. This inconsistency enables request smuggling, allowing attackers to bypass proxy-based access controls and submit unauthorized requests.

The issue was resolved by upgrading llhttp to version 9, which enforces correct header termination.

Other sources

A flaw in Node.js 20's HTTP parser allows improper termination of HTTP/1 headers using \r\n\rX instead of the required \r\n\r\n. This inconsistency enables request smuggling, allowing attackers to bypass proxy-based access controls and submit unauthorized requests.

The issue was resolved by upgrading llhttp to version 9, which enforces correct header termination.

Impact: This vulnerability affects only Node.js 20.x users prior to the llhttp v9 upgrade.

— NVD

Affected Software

5 affected componentsFixes available
Node.js Node.js<20.x
Microsoft cbl2 fluent-bit 3.0.6-2
Microsoft azl3 nodejs 20.14.0-15<24.14.1-3
24.14.1-3
Microsoft azl3 fluent-bit 3.1.9-4
Node.js Node.js>=20.0.0<20.19.2
20.19.2

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 24.14.1-3
  2. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 20.19.2
  3. Upgrade

    Upgrade llhttp to a version that resolves this vulnerability.

    Fixed in 9

Event History

May 14, 2025
CVE Published
via Node.js·03:00 AM
Data Sourced
via Node.js·03:00 AM
DescriptionSeverityAffected Software
May 19, 2025
CVE Published
via MITRE·01:25 AM
Data Sourced
via MITRE·01:25 AM
DescriptionSeverity
Data Sourced
via NVD·02:15 AM
DescriptionSeverityWeakness
Data Sourced
via OSV·02:15 AM
Description
Jul 15, 2025
Exploit Published
via GitHub·05:51 PM
Sep 4, 2025
Data Sourced
via Microsoft·07:32 AM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2025-23167?

CVE-2025-23167 is considered a critical severity vulnerability due to its potential to enable request smuggling and bypass access controls.

2

How do I fix CVE-2025-23167?

To fix CVE-2025-23167, upgrade Node.js to version 20.x or later, where this vulnerability has been resolved.

3

Which versions of Node.js are affected by CVE-2025-23167?

CVE-2025-23167 affects all Node.js versions prior to and including 20.x.

4

What kind of attacks can be executed due to CVE-2025-23167?

CVE-2025-23167 allows attackers to perform request smuggling attacks, which can lead to unauthorized request submissions.

5

How does CVE-2025-23167 affect web applications?

CVE-2025-23167 can compromise web applications by allowing attackers to bypass proxy-based access controls, posing a security risk.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203