CVE-2025-24413: Magento Stored Cross-Site Scripting (XSS) Vulnerability
Adobe Commerce versions 2.4.7-beta1, 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by a low-privileged attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field. A successful attacker can abuse this to achieve session takeover, increasing the confidentiality and integrity impact as high.
Other sources
Adobe Commerce versions 2.4.8-beta1, 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by a low-privileged attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field. A successful attacker can abuse this to achieve session takeover, increasing the confidentiality and integrity impact as high.
— NVD
Magento Stored Cross-Site Scripting (XSS) Vulnerability
— Packagist
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/magento/community-editionto a version that resolves this vulnerability.Fixed in 2.4.4-p12 - Upgrade
Upgrade
composer/magento/community-editionto a version that resolves this vulnerability.Fixed in 2.4.5-p11 - Upgrade
Upgrade
composer/magento/community-editionto a version that resolves this vulnerability.Fixed in 2.4.6-p9 - Upgrade
Upgrade
composer/magento/community-editionto a version that resolves this vulnerability.Fixed in 2.4.7-p4
Event History
Frequently Asked Questions
What is the severity of CVE-2025-24413?
CVE-2025-24413 is classified as a medium severity vulnerability due to its potential for exploitation by low-privileged attackers.
How do I fix CVE-2025-24413?
To fix CVE-2025-24413, update your Adobe Commerce version to 2.4.8 or later to mitigate the stored XSS vulnerability.
What versions are affected by CVE-2025-24413?
Adobe Commerce versions 2.4.7-beta1, 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11 and earlier are affected by CVE-2025-24413.
What type of vulnerability is CVE-2025-24413?
CVE-2025-24413 is a stored Cross-Site Scripting (XSS) vulnerability that allows attackers to inject malicious scripts.
Who can exploit CVE-2025-24413?
CVE-2025-24413 can be exploited by low-privileged attackers who have access to vulnerable form fields.