CVE-2025-31694: Drupal Two-factor Authentication (TFA) Vulnerable to Forceful Browsing

Published Mar 31, 2025
·
Updated

Drupal Two-factor Authentication (TFA) Vulnerable to Forceful Browsing

Other sources

Incorrect Authorization vulnerability in Drupal Two-factor Authentication (TFA) allows Forceful Browsing. This issue affects Two-factor Authentication (TFA): from 0.0.0 before 1.10.0.

— GitHub

Incorrect Authorization vulnerability in Drupal Two-factor Authentication (TFA) allows Forceful Browsing.This issue affects Two-factor Authentication (TFA): from 0.0.0 before 1.10.0.

— MITRE

Affected Software

4 affected componentsFixes available
Drupal Two-factor Authentication<1.10.0
composer/drupal/tfa<1.10.0
1.10.0
Two-factor Authentication Project Two-factor Authentication Drupal<8.x-1.10
composer/drupal/tfa<1.10.0
1.10.0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/drupal/tfa to a version that resolves this vulnerability.

    Fixed in 1.10.0

Event History

Mar 31, 2025
CVE Published
via MITRE·09:51 PM
Data Sourced
via MITRE·09:51 PM
DescriptionWeakness
Data Sourced
via NVD·10:15 PM
DescriptionSeverityWeaknessAffected Software
Apr 1, 2025
Advisory Published
via GitHub·12:30 AM
Data Sourced
via GitHub·12:30 AM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·12:30 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2025-31694?

CVE-2025-31694 is classified as a high-severity vulnerability due to its potential for unauthorized access.

2

How do I fix CVE-2025-31694?

To fix CVE-2025-31694, update Drupal Two-factor Authentication to version 1.10.0 or later.

3

What impact does CVE-2025-31694 have on my site?

CVE-2025-31694 allows for forceful browsing, which can lead to unauthorized access to user accounts.

4

Which versions of Drupal Two-factor Authentication are affected by CVE-2025-31694?

Versions of Drupal Two-factor Authentication prior to 1.10.0 are affected by CVE-2025-31694.

5

Is there a workaround for CVE-2025-31694 until I can update?

Currently, there are no known workarounds for CVE-2025-31694 other than applying the update.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203