CVE-2025-32802: Insecure handling of file paths allows multiple local attacks
Kea configuration and API directives can be used to overwrite arbitrary files, subject to permissions granted to Kea. Many common configurations run Kea as root, leave the API entry points unsecured by default, and/or place the control sockets in insecure paths. This issue affects Kea versions 2.4.0 through 2.4.1, 2.6.0 through 2.6.2, and 2.7.0 through 2.7.8.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Keato a version that resolves this vulnerability.Fixed in 2.4.2 - Upgrade
Upgrade
Keato a version that resolves this vulnerability.Fixed in 2.6.3 - Upgrade
Upgrade
Keato a version that resolves this vulnerability.Fixed in 2.7.9
Event History
Frequently Asked Questions
What is the severity of CVE-2025-32802?
CVE-2025-32802 has a severity rating of critical due to the potential for arbitrary file overwriting.
How do I fix CVE-2025-32802?
To fix CVE-2025-32802, you should update ISC Kea to the latest version and secure your API entry points.
What software versions are affected by CVE-2025-32802?
CVE-2025-32802 affects ISC Kea versions 2.4.0 to 2.4.1, 2.6.0 to 2.6.2, and 2.7.0 to 2.7.8.
What type of vulnerabilities does CVE-2025-32802 expose?
CVE-2025-32802 exposes vulnerabilities related to file system permissions, API security, and configuration settings.
Can CVE-2025-32802 compromise system integrity?
Yes, CVE-2025-32802 can compromise system integrity if exploited, allowing unauthorized file access and potential malicious actions.