CVE-2025-37927: iommu/amd: Fix potential buffer overflow in parse_ivrs_acpihid

Published May 20, 2025
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

iommu/amd: Fix potential buffer overflow in parseivrsacpihid

There is a string parsing logic error which can lead to an overflow of hid or uid buffers. Comparing ACPIIDLEN against a total string length doesn't take into account the lengths of individual hid and uid buffers so the check is insufficient in some cases. For example if the length of hid string is 4 and the length of the uid string is 260, the length of str will be equal to ACPIIDLEN + 1 but uid string will overflow uid buffer which size is 256.

The same applies to the hid string with length 13 and uid string with length 250.

Check the length of hid and uid strings separately to prevent buffer overflow.

Found by Linux Verification Center (linuxtesting.org) with SVACE.

Affected Software

14 affected componentsFixes available
Linux Linux kernel
Linux Linux kernel>=4.7<5.4.294
Linux Linux kernel>=5.5<5.10.238
Linux Linux kernel>=5.11<5.15.182
Linux Linux kernel>=5.16<6.1.138
Linux Linux kernel>=6.2<6.6.90
Linux Linux kernel>=6.7<6.12.28
Linux Linux kernel>=6.13<6.14.6
Linux Linux kernel=6.15-rc1
Linux Linux kernel=6.15-rc2
Linux Linux kernel=6.15-rc3
Linux Linux kernel=6.15-rc4
Debian Debian Linux=11.0
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1

Event History

May 20, 2025
CVE Published
via MITRE·03:21 PM
Data Sourced
via MITRE·03:21 PM
Description
Data Sourced
via NVD·04:15 PM
RemedyDescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2025-37927?

CVE-2025-37927 is classified as a medium severity vulnerability due to its potential to cause buffer overflows.

2

How do I fix CVE-2025-37927?

To fix CVE-2025-37927, update your Linux kernel to the latest version where the vulnerability has been patched.

3

What type of vulnerability is CVE-2025-37927?

CVE-2025-37927 is a buffer overflow vulnerability related to string parsing in the Linux kernel.

4

Which versions of the Linux kernel are affected by CVE-2025-37927?

CVE-2025-37927 affects specific versions of the Linux kernel that employ the iommu/amd functionalities.

5

What are the potential risks associated with CVE-2025-37927?

The risks of CVE-2025-37927 include possible system crashes or execution of arbitrary code due to the buffer overflow.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203