CVE-2025-38068: crypto: lzo - Fix compression buffer overrun

Published Jun 18, 2025
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

crypto: lzo - Fix compression buffer overrun

Unlike the decompression code, the compression code in LZO never checked for output overruns. It instead assumes that the caller always provides enough buffer space, disregarding the buffer length provided by the caller.

Add a safe compression interface that checks for the end of buffer before each write. Use the safe interface in crypto/lzo.

Affected Software

8 affected componentsFixes available
Linux Linux kernel
Linux Linux kernel<5.15.185
Linux Linux kernel>=5.16<6.1.141
Linux Linux kernel>=6.2<6.6.93
Linux Linux kernel>=6.7<6.12.31
Linux Linux kernel>=6.13<6.14.9
Debian Debian Linux=11.0
debian/linux
6.1.176-16.1.190-16.12.107-16.12.113-17.2.12-17.2.13-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1

Event History

Jun 18, 2025
CVE Published
via MITRE·09:33 AM
Data Sourced
via MITRE·09:33 AM
DescriptionSeverity
Data Sourced
via NVD·10:15 AM
RemedyDescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2025-38068?

CVE-2025-38068 is classified as a moderate severity vulnerability in the Linux kernel.

2

How do I fix CVE-2025-38068?

To fix CVE-2025-38068, upgrade to the patched version of the Linux kernel that addresses this vulnerability.

3

What is the impact of CVE-2025-38068?

CVE-2025-38068 can lead to potential buffer overrun issues during compression, which may compromise system stability.

4

Which versions of the Linux kernel are affected by CVE-2025-38068?

CVE-2025-38068 affects versions of the Linux kernel prior to the implementation of the fix for this vulnerability.

5

Is CVE-2025-38068 exploitable in a production environment?

Yes, CVE-2025-38068 can be exploitable in a production environment if the affected software is used without the necessary updates.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203