CVE-2025-38158: hisi_acc_vfio_pci: fix XQE dma address error

Published Jul 3, 2025
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

hisiaccvfiopci: fix XQE dma address error

The dma addresses of EQE and AEQE are wrong after migration and results in guest kernel-mode encryption services failure. Comparing the definition of hardware registers, we found that there was an error when the data read from the register was combined into an address. Therefore, the address combination sequence needs to be corrected.

Even after fixing the above problem, we still have an issue where the Guest from an old kernel can get migrated to new kernel and may result in wrong data.

In order to ensure that the address is correct after migration, if an old magic number is detected, the dma address needs to be updated.

Affected Software

7 affected componentsFixes available
Linux Linux kernel
Linux Linux kernel>=5.18<6.1.142
Linux Linux kernel>=6.2<6.6.94
Linux Linux kernel>=6.7<6.12.34
Linux Linux kernel>=6.13<6.15.3
Debian Debian Linux=11.0
debian/linux
6.1.176-16.1.190-16.12.107-16.12.113-17.2.12-17.2.13-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1
  2. Compensating control

    In hisi_acc_vfio_pci, correct the register-data address-combination sequence and update the EQE and AEQE DMA addresses when an old magic number is detected, so migrated guests receive correct addresses.

Event History

Jul 3, 2025
CVE Published
via MITRE·08:36 AM
Data Sourced
via MITRE·08:36 AM
Description
Data Sourced
via NVD·09:15 AM
RemedyDescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2025-38158?

CVE-2025-38158 has a severity rating that reflects its potential impact on the Linux kernel and the security of systems utilizing it.

2

How do I fix CVE-2025-38158?

To fix CVE-2025-38158, ensure that you update your Linux kernel to the latest stable version provided by your distribution.

3

What are the implications of CVE-2025-38158?

CVE-2025-38158 can lead to failures in guest kernel-mode encryption services, impacting the security of affected systems.

4

Which versions of Linux are affected by CVE-2025-38158?

CVE-2025-38158 affects specific versions of the Linux kernel where the vulnerability was present prior to being patched.

5

Is CVE-2025-38158 being actively exploited?

As of now, there is no public information confirming active exploitation of CVE-2025-38158.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203