CVE-2025-38212: ipc: fix to protect IPCS lookups using RCU

Published Jul 4, 2025
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

ipc: fix to protect IPCS lookups using RCU

syzbot reported that it discovered a use-after-free vulnerability, [0]

[0]: https://lore.kernel.org/all/67af13f8.050a0220.21dd3.0038.GAE@google.com/

idrforeach() is protected by rwsem, but this is not enough. If it is not protected by RCU read-critical region, when idrforeach() calls radixtreenodefree() through callrcu() to free the radixtreenode structure, the node will be freed immediately, and when reading the next node in radixtreeforeachslot(), the already freed memory may be read.

Therefore, we need to add code to make sure that idrforeach() is protected within the RCU read-critical region when we call it in shmdestroyorphaned().

Affected Software

12 affected componentsFixes available
Linux Linux kernel
Microsoft azl3 kernel 6.6.92.2-2
Microsoft azl3 kernel 6.6.96.1-1
Linux Linux kernel>=3.1<5.4.295
Linux Linux kernel>=5.5<5.10.239
Linux Linux kernel>=5.11<5.15.186
Linux Linux kernel>=5.16<6.1.142
Linux Linux kernel>=6.2<6.6.95
Linux Linux kernel>=6.7<6.12.35
Linux Linux kernel>=6.13<6.15.4
Debian Debian Linux=11.0
debian/linux
6.1.176-16.1.190-16.12.107-16.12.113-17.2.12-17.2.13-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1
  2. Compensating control

    Protect the idr_for_each() call in shm_destroy_orphaned() within an RCU read-critical region to prevent radix_tree_node use-after-free during IPCS lookups.

Event History

Jul 4, 2025
CVE Published
via MITRE·01:37 PM
Data Sourced
via MITRE·01:37 PM
DescriptionSeverity
Data Sourced
via NVD·02:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Aug 7, 2025
Data Sourced
via Microsoft·07:00 AM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2025-38212?

CVE-2025-38212 is classified as a high-severity vulnerability due to its potential for causing use-after-free errors.

2

How do I fix CVE-2025-38212?

To fix CVE-2025-38212, update your Linux kernel to the latest stable version that addresses the vulnerability.

3

What are the potential impacts of CVE-2025-38212?

The potential impacts of CVE-2025-38212 include information disclosure and system compromise due to the use-after-free vulnerability.

4

Which versions of the Linux kernel are affected by CVE-2025-38212?

CVE-2025-38212 affects multiple versions of the Linux kernel prior to the release of the patch.

5

How can I determine if my system is vulnerable to CVE-2025-38212?

You can determine if your system is vulnerable to CVE-2025-38212 by checking your Linux kernel version against the patched releases.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203