CVE-2025-38280: bpf: Avoid __bpf_prog_ret0_warn when jit fails

Published Jul 10, 2025
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

bpf: Avoid bpfprogret0warn when jit fails

syzkaller reported an issue:

WARNING: CPU: 3 PID: 217 at kernel/bpf/core.c:2357 bpfprogret0warn+0xa/0x20 kernel/bpf/core.c:2357 Modules linked in: CPU: 3 UID: 0 PID: 217 Comm: kworker/u32:6 Not tainted 6.15.0-rc4-syzkaller-00040-g8bac8898fe39 RIP: 0010:bpfprogret0warn+0xa/0x20 kernel/bpf/core.c:2357 Call Trace: <TASK> bpfdispatchernopfunc include/linux/bpf.h:1316 [inline] bpfprogrun include/linux/filter.h:718 [inline] bpfprogrun include/linux/filter.h:725 [inline] clsbpfclassify+0x74a/0x1110 net/sched/clsbpf.c:105 ...

When creating bpf program, 'fp->jitrequested' depends on bpfjitenable. This issue is triggered because of CONFIGBPFJITALWAYSON is not set and bpfjitenable is set to 1, causing the arch to attempt JIT the prog, but jit failed due to FAULTINJECTION. As a result, incorrectly treats the program as valid, when the program runs it calls bpfprogret0warn and triggers the WARNONONCE(1).

Affected Software

10 affected componentsFixes available
Linux Kernel
Linux Linux kernel>=4.9.190<4.10
Linux Linux kernel>=4.14.140<4.15
Linux Linux kernel>=4.16<5.15.186
Linux Linux kernel>=5.16<6.1.142
Linux Linux kernel>=6.2<6.6.94
Linux Linux kernel>=6.7<6.12.34
Linux Linux kernel>=6.13<6.15.3
Debian Debian Linux=11.0
debian/linux
6.1.176-16.1.190-16.12.107-16.12.113-17.2.12-17.2.13-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1

Event History

Jul 10, 2025
CVE Published
via MITRE·07:41 AM
Data Sourced
via MITRE·07:41 AM
Description
Data Sourced
via NVD·08:15 AM
RemedyDescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2025-38280?

The severity of CVE-2025-38280 is considered moderate, as it pertains to a specific handling issue in the Linux kernel.

2

How do I fix CVE-2025-38280?

To fix CVE-2025-38280, upgrade to the latest version of the Linux kernel that addresses this vulnerability.

3

What systems are affected by CVE-2025-38280?

CVE-2025-38280 affects various versions of the Linux kernel, particularly those using BPF (Berkeley Packet Filter).

4

What could happen if CVE-2025-38280 is exploited?

If exploited, CVE-2025-38280 could potentially lead to a denial of service condition in the affected Linux systems.

5

Is there a workaround for CVE-2025-38280?

Currently, there are no specific workarounds for CVE-2025-38280, so updating the kernel is the recommended approach.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203