CVE-2025-38332: scsi: lpfc: Use memcpy() for BIOS version

Published Jul 10, 2025
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

scsi: lpfc: Use memcpy() for BIOS version

The strlcat() with FORTIFY support is triggering a panic because it thinks the target buffer will overflow although the correct target buffer size is passed in.

Anyway, instead of memset() with 0 followed by a strlcat(), just use memcpy() and ensure that the resulting buffer is NULL terminated.

BIOSVersion is only used for the lpfcprintflog() which expects a properly terminated string.

Affected Software

10 affected componentsFixes available
Linux Kernel
Linux Linux kernel<5.4.295
Linux Linux kernel>=5.5<5.10.239
Linux Linux kernel>=5.11<5.15.186
Linux Linux kernel>=5.16<6.1.142
Linux Linux kernel>=6.2<6.6.95
Linux Linux kernel>=6.7<6.12.35
Linux Linux kernel>=6.13<6.15.4
Debian Debian Linux=11.0
debian/linux
6.1.176-16.1.190-16.12.107-16.12.113-17.2.12-17.2.13-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1
  2. Compensating control

    Replace the strlcat() operation used for the BIOSVersion buffer with memcpy(), and ensure the resulting buffer is NULL terminated before passing it to lpfc_printf_log().

Event History

Jul 10, 2025
CVE Published
via MITRE·08:15 AM
Data Sourced
via MITRE·08:15 AM
Description
Data Sourced
via Red Hat·09:02 AM
DescriptionSeverityAffected Software
Data Sourced
via NVD·09:15 AM
RemedyDescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2025-38332?

CVE-2025-38332 has a moderate severity level due to its potential to cause panic in the system.

2

How do I fix CVE-2025-38332?

To fix CVE-2025-38332, you should apply the latest Linux kernel updates that address this vulnerability.

3

What systems are affected by CVE-2025-38332?

CVE-2025-38332 affects the Linux kernel, specifically the SCSI lpfc driver.

4

What is the nature of the vulnerability in CVE-2025-38332?

The vulnerability in CVE-2025-38332 is caused by improper handling of buffer sizes in strlcat(), leading to potential kernel panic.

5

Is there a patch available for CVE-2025-38332?

Yes, there are patches available in the updates for the Linux kernel that resolve CVE-2025-38332.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203