CVE-2025-38412: platform/x86: dell-wmi-sysman: Fix WMI data block retrieval in sysfs callbacks

Published Jul 25, 2025
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

platform/x86: dell-wmi-sysman: Fix WMI data block retrieval in sysfs callbacks

After retrieving WMI data blocks in sysfs callbacks, check for the validity of them before dereferencing their content.

Affected Software

15 affected componentsFixes available
Linux Kernel
Microsoft azl3 kernel 6.6.96.2-1
Microsoft azl3 kernel 6.6.96.2-2
Microsoft cbl2 kernel 5.15.186.1-1
Linux Linux kernel>=5.11<5.15.187
Linux Linux kernel>=5.16<6.1.144
Linux Linux kernel>=6.2<6.6.97
Linux Linux kernel>=6.7<6.12.37
Linux Linux kernel>=6.13<6.15.6
Linux Linux kernel=6.16-rc1
Linux Linux kernel=6.16-rc2
Linux Linux kernel=6.16-rc3
Linux Linux kernel=6.16-rc4
Debian Debian Linux=11.0
debian/linux
6.1.176-16.1.190-16.12.107-16.12.113-17.2.12-17.2.13-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1
  2. Compensating control

    In platform/x86/dell-wmi-sysman sysfs callbacks, validate the retrieved WMI data blocks before dereferencing their contents.

Event History

Jul 25, 2025
CVE Published
via MITRE·01:20 PM
Data Sourced
via MITRE·01:20 PM
DescriptionSeverity
Data Sourced
via Red Hat·02:02 PM
DescriptionSeverityAffected Software
Data Sourced
via NVD·02:15 PM
RemedyDescriptionSeverityAffected Software
Sep 4, 2025
Data Sourced
via Microsoft·04:58 AM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2025-38412?

CVE-2025-38412 has been classified as a medium severity vulnerability.

2

How do I fix CVE-2025-38412?

To resolve CVE-2025-38412, you should update your Linux kernel to the latest patched version.

3

What systems are affected by CVE-2025-38412?

CVE-2025-38412 affects various versions of the Linux kernel that utilize dell-wmi-sysman.

4

What type of vulnerability is CVE-2025-38412?

CVE-2025-38412 is a security vulnerability in the Linux kernel related to improper validation of WMI data blocks.

5

Can CVE-2025-38412 be exploited remotely?

CVE-2025-38412 may allow local attackers to exploit the vulnerability, but it is not known to be exploitable remotely.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203