CVE-2025-38466: perf: Revert to requiring CAP_SYS_ADMIN for uprobes

Published Jul 25, 2025
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

perf: Revert to requiring CAPSYSADMIN for uprobes

Jann reports that uprobes can be used destructively when used in the middle of an instruction. The kernel only verifies there is a valid instruction at the requested offset, but due to variable instruction length cannot determine if this is an instruction as seen by the intended execution stream.

Additionally, Mark Rutland notes that on architectures that mix data in the text segment (like arm64), a similar things can be done if the data word is 'mistaken' for an instruction.

As such, require CAPSYSADMIN for uprobes.

Affected Software

16 affected componentsFixes available
Linux Kernel
Microsoft azl3 kernel 6.6.96.2-1
Microsoft azl3 kernel 6.6.96.2-2
Microsoft cbl2 kernel 5.15.186.1-1
Linux Linux kernel>=5.8<5.10.240
Linux Linux kernel>=5.11<5.15.189
Linux Linux kernel>=5.16<6.1.146
Linux Linux kernel>=6.2<6.6.99
Linux Linux kernel>=6.7<6.12.39
Linux Linux kernel>=6.13<6.15.7
Linux Linux kernel=6.16-rc1
Linux Linux kernel=6.16-rc2
Linux Linux kernel=6.16-rc3
Linux Linux kernel=6.16-rc4
Debian Debian Linux=11.0
debian/linux
6.1.176-16.1.190-16.12.107-16.12.113-17.2.12-17.2.13-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1
  2. Compensating control

    Require CAP_SYS_ADMIN for uprobes.

Event History

Jul 25, 2025
CVE Published
via MITRE·03:27 PM
Data Sourced
via MITRE·03:27 PM
DescriptionSeverity
Data Sourced
via NVD·04:15 PM
RemedyDescriptionSeverityAffected Software
Sep 3, 2025
Data Sourced
via Microsoft·09:49 PM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2025-38466?

CVE-2025-38466 has been classified as a serious vulnerability affecting the Linux kernel.

2

How does CVE-2025-38466 affect Linux kernel security?

CVE-2025-38466 allows destructive use of uprobes, potentially compromising system integrity.

3

How do I fix CVE-2025-38466?

To fix CVE-2025-38466, ensure you update to the latest stable version of the Linux kernel that includes the security patch.

4

Who reported CVE-2025-38466?

CVE-2025-38466 was reported by a researcher named Jann.

5

What action is required regarding CAP_SYS_ADMIN for uprobes in CVE-2025-38466?

CVE-2025-38466 requires reverting to requiring CAP_SYS_ADMIN privileges for the use of uprobes in the Linux kernel.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203