CVE-2025-38483: comedi: das16m1: Fix bit shift out of bounds

Published Jul 28, 2025
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

comedi: das16m1: Fix bit shift out of bounds

When checking for a supported IRQ number, the following test is used:

/ only irqs 2, 3, 4, 5, 6, 7, 10, 11, 12, 14, and 15 are valid / if ((1 << it->options[1]) & 0xdcfc) {

However, it->options[i] is an unchecked int value from userspace, so the shift amount could be negative or out of bounds. Fix the test by requiring it->options[1] to be within bounds before proceeding with the original test.

Affected Software

16 affected componentsFixes available
Linux Kernel
Linux Linux kernel>=3.14<5.4.297
Linux Linux kernel>=5.5<5.10.241
Linux Linux kernel>=5.11<5.15.190
Linux Linux kernel>=5.16<6.1.147
Linux Linux kernel>=6.2<6.6.100
Linux Linux kernel>=6.7<6.12.40
Linux Linux kernel>=6.13<6.15.8
Linux Linux kernel=6.16-rc1
Linux Linux kernel=6.16-rc2
Linux Linux kernel=6.16-rc3
Linux Linux kernel=6.16-rc4
Linux Linux kernel=6.16-rc5
Linux Linux kernel=6.16-rc6
Debian Debian Linux=11.0
debian/linux
6.1.176-16.1.190-16.12.107-16.12.113-17.2.12-17.2.13-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1

Event History

Jul 28, 2025
CVE Published
via MITRE·11:21 AM
Data Sourced
via MITRE·11:21 AM
Description
Data Sourced
via NVD·12:15 PM
RemedyDescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2025-38483?

CVE-2025-38483 is rated as a medium severity vulnerability due to improper checking of IRQ numbers in the Linux kernel.

2

How does CVE-2025-38483 affect systems running the Linux kernel?

CVE-2025-38483 can lead to potential out-of-bounds bit shifts affecting system stability and security in devices using the affected kernel.

3

What versions of the Linux kernel are impacted by CVE-2025-38483?

CVE-2025-38483 affects multiple versions of the Linux kernel, particularly those that utilize the comedi das16m1 driver.

4

How do I fix CVE-2025-38483 in my Linux kernel?

To fix CVE-2025-38483, update your Linux kernel to the latest patched version provided by your distribution.

5

Is CVE-2025-38483 actively being exploited?

As of now, there are no publicly reported active exploits for CVE-2025-38483, but it is advisable to apply patches.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203