CVE-2025-38494: HID: core: do not bypass hid_hw_raw_request

Published Jul 28, 2025
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

HID: core: do not bypass hidhwrawrequest

hidhwrawrequest() is actually useful to ensure the provided buffer and length are valid. Directly calling in the low level transport driver function bypassed those checks and allowed invalid paramto be used.

Affected Software

16 affected componentsFixes available
Linux Kernel
Linux Linux kernel>=3.15<5.4.297
Linux Linux kernel>=5.5<5.10.241
Linux Linux kernel>=5.11<5.15.190
Linux Linux kernel>=5.16<6.1.147
Linux Linux kernel>=6.2<6.6.100
Linux Linux kernel>=6.7<6.12.40
Linux Linux kernel>=6.13<6.15.8
Linux Linux kernel=6.16-rc1
Linux Linux kernel=6.16-rc2
Linux Linux kernel=6.16-rc3
Linux Linux kernel=6.16-rc4
Linux Linux kernel=6.16-rc5
Linux Linux kernel=6.16-rc6
Debian Debian Linux=11.0
debian/linux
6.1.176-16.1.190-16.12.107-16.12.113-17.2.12-17.2.13-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1

Event History

Jul 28, 2025
CVE Published
via MITRE·11:22 AM
Data Sourced
via MITRE·11:22 AM
DescriptionSeverity
Data Sourced
via NVD·12:15 PM
RemedyDescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2025-38494?

CVE-2025-38494 is classified as a medium severity vulnerability in the Linux kernel.

2

How do I fix CVE-2025-38494?

To fix CVE-2025-38494, upgrade to the patched version of the Linux kernel provided by your distribution.

3

What systems are affected by CVE-2025-38494?

CVE-2025-38494 affects various versions of the Linux kernel that utilize the HID subsystem.

4

What type of vulnerability is CVE-2025-38494?

CVE-2025-38494 is a coding issue related to the HID (Human Interface Device) subsystem in the Linux kernel.

5

Can CVE-2025-38494 be exploited remotely?

CVE-2025-38494 does not represent a direct remote exploit, but it can impact systems with vulnerable kernel configurations.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203