CVE-2025-38687: comedi: fix race between polling and detaching

Published Sep 4, 2025
·
Updated

comedi: fix race between polling and detaching

Affected Software

13 affected componentsFixes available
Linux Kernel
Microsoft azl3 kernel 6.6.96.2-1
Microsoft azl3 kernel 6.6.96.2-2
Linux Linux kernel>=3.14<5.4.297
Linux Linux kernel>=5.5<5.10.241
Linux Linux kernel>=5.11<5.15.190
Linux Linux kernel>=5.16<6.1.149
Linux Linux kernel>=6.2<6.6.103
Linux Linux kernel>=6.7<6.12.43
Linux Linux kernel>=6.13<6.15.11
Linux Linux kernel>=6.16<6.16.2
Debian Debian Linux=11.0
debian/linux
6.1.176-16.1.190-16.12.107-16.12.113-17.2.12-17.2.13-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1

Event History

Sep 4, 2025
CVE Published
via MITRE·03:32 PM
Data Sourced
via MITRE·03:32 PM
DescriptionSeverity
Data Sourced
via NVD·04:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Sep 6, 2025
Data Sourced
via Microsoft·01:09 AM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2025-38687?

CVE-2025-38687 is classified as a medium severity vulnerability in the Linux kernel.

2

How do I fix CVE-2025-38687?

To fix CVE-2025-38687, update your Linux kernel to the latest stable version that contains the patch addressing this vulnerability.

3

What causes the CVE-2025-38687 vulnerability?

CVE-2025-38687 is caused by a race condition between polling and detaching in the comedi driver, leading to a use-after-free condition.

4

Which Linux kernel versions are affected by CVE-2025-38687?

CVE-2025-38687 affects various versions of the Linux kernel where the comedi driver is implemented.

5

Is CVE-2025-38687 a remote exploit?

CVE-2025-38687 is not classified as a remote exploit, but it can potentially be triggered by local users with access to the comedi driver.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203