CVE-2025-39685: comedi: pcl726: Prevent invalid irq number

Published Sep 5, 2025
·
Updated

comedi: pcl726: Prevent invalid irq number

Affected Software

12 affected componentsFixes available
Linux Kernel
Microsoft azl3 kernel 6.6.96.2-1
Microsoft azl3 kernel 6.6.96.2-2
Linux Linux kernel>=3.13<5.15.190
Linux Linux kernel>=5.16<6.1.149
Linux Linux kernel>=6.2<6.6.103
Linux Linux kernel>=6.7<6.12.44
Linux Linux kernel>=6.13<6.16.4
Linux Linux kernel=6.17-rc1
Linux Linux kernel=6.17-rc2
Debian Debian Linux=11.0
debian/linux
6.1.176-16.1.190-16.12.107-16.12.113-17.2.12-17.2.13-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1
  2. Compensating control

    In comedi pcl726, reject `it->options[1]` IRQ values above 30 before shifting, or use `1U << it->options[1]` to avoid shifting a 1-bit into the sign bit.

  3. Compensating control

    Do not configure the device without interrupts when `request_irq` returns an error; treat the IRQ request failure as a failure of device configuration.

Event History

Sep 5, 2025
CVE Published
via MITRE·05:20 PM
Data Sourced
via MITRE·05:20 PM
Description
Data Sourced
via NVD·06:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Sep 7, 2025
Data Sourced
via Microsoft·01:03 AM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2025-39685?

CVE-2025-39685 has been classified as a moderate-severity vulnerability due to the potential for out-of-bounds access.

2

How do I fix CVE-2025-39685?

To fix CVE-2025-39685, update your Linux kernel to the latest version where this vulnerability has been patched.

3

What systems are affected by CVE-2025-39685?

CVE-2025-39685 affects certain versions of the Linux kernel that utilize the comedi subsystem.

4

What does CVE-2025-39685 exploit?

CVE-2025-39685 exploits the ability to pass an excessively large IRQ number, causing an out-of-bounds access.

5

Is CVE-2025-39685 being actively exploited in the wild?

As of now, there is no publicly available information indicating that CVE-2025-39685 is being actively exploited.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203