CVE-2025-39815: RISC-V: KVM: fix stack overrun when loading vlenb

Published Sep 16, 2025
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

RISC-V: KVM: fix stack overrun when loading vlenb

The userspace load can put up to 2048 bits into an xlen bit stack buffer. We want only xlen bits, so check the size beforehand.

Affected Software

7 affected componentsFixes available
Linux Kernel
Linux Linux kernel>=6.8<6.12.45
Linux Linux kernel>=6.13<6.16.5
Linux Linux kernel=6.17-rc1
Linux Linux kernel=6.17-rc2
Linux Linux kernel=6.17-rc3
debian/linux
6.1.176-16.1.190-16.12.107-16.12.113-17.2.12-17.2.13-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1
  2. Compensating control

    In RISC-V KVM, validate the userspace load size before loading vlenb into the stack buffer, accepting only xlen bits to prevent up to 2048 bits from overflowing the xlen-bit buffer.

Event History

Sep 16, 2025
CVE Published
via MITRE·01:00 PM
Data Sourced
via MITRE·01:00 PM
DescriptionSeverity
Data Sourced
via NVD·01:15 PM
RemedyDescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2025-39815?

CVE-2025-39815 has been rated as a high severity vulnerability due to the potential for stack overflows in the Linux kernel.

2

How do I fix CVE-2025-39815?

To fix CVE-2025-39815, users should update their Linux kernel to the latest patched version that addresses this vulnerability.

3

What are the potential impacts of CVE-2025-39815?

The potential impacts of CVE-2025-39815 include system crashes or arbitrary code execution resulting from a stack overrun.

4

Which versions of Linux Kernel are affected by CVE-2025-39815?

CVE-2025-39815 affects multiple versions of the Linux Kernel; specifically, any version that allows the stack buffer to be overloaded.

5

Is CVE-2025-39815 publicly known?

Yes, CVE-2025-39815 is a publicly known vulnerability, and it has been documented in various security advisories.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203