CVE-2025-39823: KVM: x86: use array_index_nospec with indices that come from guest

Published Sep 16, 2025
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

KVM: x86: use arrayindexnospec with indices that come from guest

min and destid are guest-controlled indices. Using arrayindexnospec() after the bounds checks clamps these values to mitigate speculative execution side-channels.

Affected Software

15 affected componentsFixes available
Linux Kernel
Microsoft azl3 kernel 6.6.96.2-2
Microsoft cbl2 kernel 5.15.186.1-1
Linux Linux kernel>=4.19<5.4.298
Linux Linux kernel>=5.5<5.10.242
Linux Linux kernel>=5.11<5.15.191
Linux Linux kernel>=5.16<6.1.150
Linux Linux kernel>=6.2<6.6.104
Linux Linux kernel>=6.7<6.12.45
Linux Linux kernel>=6.13<6.16.5
Linux Linux kernel=6.17-rc1
Linux Linux kernel=6.17-rc2
Linux Linux kernel=6.17-rc3
Debian Debian Linux=11.0
debian/linux
6.1.176-16.1.190-16.12.107-16.12.113-17.2.12-17.2.13-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1

Event History

Sep 16, 2025
CVE Published
via MITRE·01:00 PM
Data Sourced
via MITRE·01:00 PM
Description
Data Sourced
via NVD·01:16 PM
RemedyDescriptionSeverityWeaknessAffected Software
Sep 20, 2025
Data Sourced
via Microsoft·01:09 AM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2025-39823?

CVE-2025-39823 is classified as a medium severity vulnerability in the Linux kernel.

2

How do I fix CVE-2025-39823?

To fix CVE-2025-39823, update your Linux kernel to the latest version that includes the fix.

3

What platforms are affected by CVE-2025-39823?

CVE-2025-39823 affects all versions of the Linux kernel that are vulnerable to the issue related to KVM and guest-controlled indices.

4

What is the impact of CVE-2025-39823 on system security?

CVE-2025-39823 allows an attacker to potentially exploit guest-controlled indices, which may lead to information disclosure or system compromise.

5

Who is responsible for patching CVE-2025-39823?

The responsibility for patching CVE-2025-39823 falls on system administrators and users running affected versions of the Linux kernel.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203