CVE-2025-39828: atm: atmtcp: Prevent arbitrary write in atmtcp_recv_control().

Published Sep 16, 2025
·
Updated

atm: atmtcp: Prevent arbitrary write in atmtcprecvcontrol().

Affected Software

19 affected componentsFixes available
Linux Linux kernel
Microsoft azl3 kernel 6.6.96.2-2
Linux Linux kernel>=2.6.12.1<5.4.298
Linux Linux kernel>=5.5<5.10.242
Linux Linux kernel>=5.11<5.15.191
Linux Linux kernel>=5.16<6.1.150
Linux Linux kernel>=6.2<6.6.104
Linux Linux kernel>=6.7<6.12.45
Linux Linux kernel>=6.13<6.16.5
Linux Linux kernel=2.6.12
Linux Linux kernel=2.6.12-rc2
Linux Linux kernel=2.6.12-rc3
Linux Linux kernel=2.6.12-rc4
Linux Linux kernel=2.6.12-rc5
Linux Linux kernel=6.17-rc1
Linux Linux kernel=6.17-rc2
Linux Linux kernel=6.17-rc3
Debian Debian Linux=11.0
debian/linux
6.1.176-16.1.190-16.12.107-16.12.113-17.2.12-17.2.13-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1
  2. Compensating control

    Add a new ->pre_send() hook for atmtcp to validate message length and reject malformed messages submitted through sendmsg() before atmtcp_recv_control() processes them.

Event History

Sep 16, 2025
CVE Published
via MITRE·01:00 PM
Data Sourced
via MITRE·01:00 PM
Description
Data Sourced
via NVD·01:16 PM
RemedyDescriptionSeverityAffected Software
Sep 20, 2025
Data Sourced
via Microsoft·01:08 AM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2025-39828?

CVE-2025-39828 has a high severity rating due to its potential to allow arbitrary write operations in the Linux kernel.

2

How do I fix CVE-2025-39828?

To fix CVE-2025-39828, you should upgrade to the latest version of the Linux kernel that addresses this vulnerability.

3

What are the potential impacts of CVE-2025-39828?

CVEs such as CVE-2025-39828 can lead to system compromise by allowing unauthorized write access to kernel memory.

4

Which versions of the Linux kernel are affected by CVE-2025-39828?

CVE-2025-39828 affects various versions of the Linux kernel that contain vulnerabilities in the atmtcp component.

5

Is CVE-2025-39828 being actively exploited?

As of the latest reports, there are indications that CVE-2025-39828 may be targeted by active exploitation, making timely remediation essential.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203