CVE-2025-39849: wifi: cfg80211: sme: cap SSID length in __cfg80211_connect_result()

Published Sep 19, 2025
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

wifi: cfg80211: sme: cap SSID length in cfg80211connectresult()

If the ssid->datalen is more than IEEE80211MAXSSIDLEN (32) it would lead to memory corruption so add some bounds checking.

Other sources

In the Linux kernel, the following vulnerability has been resolved:

wifi: cfg80211: sme: cap SSID length in cfg80211connectresult()

If the ssid-datalen is more than IEEE80211MAXSSIDLEN (32) it would lead to memory corruption so add some bounds checking.

— IBM

Affected Software

14 affected componentsFixes available
Linux Kernel
Microsoft azl3 kernel 6.6.96.2-2
Microsoft azl3 kernel 6.6.104.2-4
IBM Cloud Pak for Data System<=1.0.0.0- 1.0.8.4
Linux Linux kernel>=6.1.16<6.1.151
Linux Linux kernel>=6.2.3<6.6.105
Linux Linux kernel>=6.7<6.12.46
Linux Linux kernel>=6.13<6.16.6
Linux Linux kernel=6.17-rc1
Linux Linux kernel=6.17-rc2
Linux Linux kernel=6.17-rc3
Linux Linux kernel=6.17-rc4
Debian Debian Linux=11.0
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1
  2. Compensating control

    In cfg80211 SME __cfg80211_connect_result(), cap SSID length and add bounds checking so ssid->datalen cannot exceed IEEE80211_MAX_SSID_LEN (32).

Event History

Sep 19, 2025
CVE Published
via MITRE·03:26 PM
Data Sourced
via MITRE·03:26 PM
DescriptionSeverity
Data Sourced
via Red Hat·04:02 PM
DescriptionSeverityAffected Software
Data Sourced
via NVD·04:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Sep 21, 2025
Data Sourced
via Microsoft·01:01 AM
DescriptionSeverityWeaknessAffected Software
Sep 1, 2026
Data Sourced
via IBM·12:00 AM
DescriptionAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2025-39849?

CVE-2025-39849 is considered a high-severity vulnerability due to the risk of memory corruption.

2

How do I fix CVE-2025-39849?

To fix CVE-2025-39849, upgrade your Linux Kernel to a version that includes the patch addressing this vulnerability.

3

How does CVE-2025-39849 affect system security?

CVE-2025-39849 can lead to potential system crashes or arbitrary code execution by allowing memory corruption.

4

What versions of the Linux Kernel are affected by CVE-2025-39849?

CVE-2025-39849 affects multiple versions of the Linux Kernel prior to the patch implementation.

5

What type of attack can exploit CVE-2025-39849?

Exploitation of CVE-2025-39849 can occur through crafted SSID inputs that exceed the maximum length, leading to memory corruption.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203