CVE-2025-46148: Medium severity PyTorch PyTorch vulnerability
In PyTorch through 2.6.0, when eager is used, nn.PairwiseDistance(p=2) produces incorrect results.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/pytorchto a version that resolves this vulnerability.Fixed in 2.12.0+dfsg2-1 - Upgrade
Upgrade
debian/pytorchto a version that resolves this vulnerability.Fixed in 2.14.1+dfsg-1
Event History
Frequently Asked Questions
What is the severity of CVE-2025-46148?
CVE-2025-46148 has been classified with a moderate severity due to potential inaccuracies in result outputs.
How do I fix CVE-2025-46148?
To fix CVE-2025-46148, upgrade PyTorch to version 2.6.1 or later where the issue is addressed.
What systems are affected by CVE-2025-46148?
CVE-2025-46148 affects all versions of PyTorch up to and including 2.6.0.
What is the impact of using CVE-2025-46148 in production?
Using CVE-2025-46148 in production can lead to incorrect results in calculations involving nn.PairwiseDistance(p=2).
Is there a workaround for CVE-2025-46148 before upgrading?
Currently, there are no recommended workarounds for CVE-2025-46148 other than upgrading to a fixed version.