CVE-2025-46819: Redis is vulnerable to DoS via specially crafted LUA scripts
Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted LUA script to read out-of-bound data or crash the server and subsequent denial of service. The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2. To workaround this issue without patching the redis-server executable is to prevent users from executing Lua scripts. This can be done using ACL to block a script by restricting both the EVAL and FUNCTION command families.
Other sources
Redis is vulnerable to DoS via specially crafted LUA scripts
— Microsoft
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/redictto a version that resolves this vulnerability.Fixed in 7.3.6-r0 - Upgrade
Upgrade
alpine/redisto a version that resolves this vulnerability.Fixed in 7.2.11-r0 - Upgrade
Upgrade
alpine/redisto a version that resolves this vulnerability.Fixed in 8.0.4-r0 - Upgrade
Upgrade
alpine/redisto a version that resolves this vulnerability.Fixed in 8.2.2-r0 - Upgrade
Upgrade
alpine/valkeyto a version that resolves this vulnerability.Fixed in 7.2.11-r0 - Upgrade
Upgrade
alpine/valkeyto a version that resolves this vulnerability.Fixed in 8.1.4-r0 - Upgrade
Upgrade
Redisto a version that resolves this vulnerability.Fixed in 8.2.2 - Configuration
Use ACLs to prevent users from executing Lua scripts by restricting both the EVAL and FUNCTION command families.
Redis ACL command access = Block the EVAL and FUNCTION command families
Event History
Frequently Asked Questions
What is the severity of CVE-2025-46819?
CVE-2025-46819 has a severity rating that indicates a potential denial of service due to out-of-bound data access.
How do I fix CVE-2025-46819?
To fix CVE-2025-46819, update Redis to version 8.2.2 or higher.
What versions are affected by CVE-2025-46819?
CVE-2025-46819 affects Redis versions 8.2.1 and below.
What type of vulnerability is CVE-2025-46819?
CVE-2025-46819 is a denial of service vulnerability that can be triggered by a specially crafted LUA script.
Who can exploit CVE-2025-46819?
CVE-2025-46819 can be exploited by an authenticated user with permissions to execute LUA scripts.