CVE-2025-47940: TYPO3 Allows Privilege Escalation to System Maintainer
Problem Administrator-level backend users without system maintainer privileges can escalate their privileges and gain system maintainer access. Exploiting this vulnerability requires a valid administrator account.
Solution Update to TYPO3 versions 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, 13.4.12 LTS that fix the problem described.
Credits Thanks to Alexander Künzl for reporting this issue, and to TYPO3 core & security team member Oliver Hader for fixing it.
Other sources
TYPO3 Allows Privilege Escalation to System Maintainer
— Packagist
TYPO3 is an open source, PHP based web content management system. Starting in version 10.0.0 and prior to versions 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, and 13.4.12 LTS, administrator-level backend users without system maintainer privileges can escalate their privileges and gain system maintainer access. Exploiting this vulnerability requires a valid administrator account. Users should update to TYPO3 version 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, or 13.4.12 LTS to fix the problem.
— MITRE
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/typo3/cms-coreto a version that resolves this vulnerability.Fixed in 13.4.12 - Upgrade
Upgrade
composer/typo3/cms-coreto a version that resolves this vulnerability.Fixed in 12.4.31 - Upgrade
Upgrade
composer/typo3/cms-coreto a version that resolves this vulnerability.Fixed in 11.5.44 - Upgrade
Upgrade
composer/typo3/cms-coreto a version that resolves this vulnerability.Fixed in 10.4.50 - Upgrade
Upgrade
TYPO3 CMSto a version that resolves this vulnerability.Fixed in 10.4.50 ELTS - Upgrade
Upgrade
TYPO3 CMSto a version that resolves this vulnerability.Fixed in 11.5.44 ELTS - Upgrade
Upgrade
TYPO3 CMSto a version that resolves this vulnerability.Fixed in 12.4.31 LTS - Upgrade
Upgrade
TYPO3 CMSto a version that resolves this vulnerability.Fixed in 13.4.12 LTS
Event History
Frequently Asked Questions
What is the severity of CVE-2025-47940?
The severity of CVE-2025-47940 is critical due to the potential for privilege escalation by administrator-level users.
How do I fix CVE-2025-47940?
To fix CVE-2025-47940, update TYPO3 to versions 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, or 13.4.12 LTS or later.
Who is affected by CVE-2025-47940?
Organizations using TYPO3 versions 10.0.0 through 10.4.50, 11.5.44, 12.4.31, or 13.4.12 are affected by CVE-2025-47940.
What type of vulnerability is CVE-2025-47940?
CVE-2025-47940 is a privilege escalation vulnerability in the TYPO3 backend.
Can I still use TYPO3 if I have CVE-2025-47940?
If your TYPO3 instance is affected by CVE-2025-47940, it is highly recommended to apply the necessary updates to prevent security risks.