CVE-2025-53905: Vim has path traversial issue with tar.vim and special crafted tar files
Vim is an open source, command line text editor. Prior to version 9.1.1552, a path traversal issue in Vim’s tar.vim plugin can allow overwriting of arbitrary files when opening specially crafted tar archives. Impact is low because this exploit requires direct user interaction. However, successfully exploitation can lead to overwriting sensitive files or placing executable code in privileged locations, depending on the permissions of the process editing the archive. The victim must edit such a file using Vim which will reveal the filename and the file content, a careful user may suspect some strange things going on. Successful exploitation could results in the ability to execute arbitrary commands on the underlying operating system. Version 9.1.1552 contains a patch for the vulnerability.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/vimto a version that resolves this vulnerability.Fixed in 2:9.1.1230-2+deb13u1 - Upgrade
Upgrade
debian/vimto a version that resolves this vulnerability.Fixed in 2:9.1.1829-1 - Upgrade
Upgrade
debian/vimto a version that resolves this vulnerability.Fixed in 2:9.1.1230-2+deb13u1Fixed in 2:9.2.0858-1 - Upgrade
Upgrade
Vimto a version that resolves this vulnerability.Fixed in 9.1.1552
Event History
Frequently Asked Questions
What is the severity of CVE-2025-53905?
The severity of CVE-2025-53905 is considered low due to the requirement of direct user interaction for exploitation.
How do I fix CVE-2025-53905?
To fix CVE-2025-53905, upgrade to Vim version 9.1.1552 or later.
What does CVE-2025-53905 involve?
CVE-2025-53905 involves a path traversal issue in Vim’s tar.vim plugin that allows overwriting of arbitrary files from specially crafted tar archives.
Which versions of Vim are affected by CVE-2025-53905?
Vim versions prior to 9.1.1552 are affected by CVE-2025-53905.
What is the impact of CVE-2025-53905?
The impact of CVE-2025-53905 is low, as it requires direct user interaction to exploit.