CVE-2025-55073: MS Teams plugin OAuth allows editing arbitrary posts
Mattermost versions 10.11.x <= 10.11.3, 10.5.x <= 10.5.11, 10.12.x <= 10.12.0 fail to validate the relationship between the post being updated and the MSTeams plugin OAuth flow which allows an attacker to edit arbitrary posts via a crafted MSTeams plugin OAuth redirect URL.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
go/github.com/mattermost/mattermost/server/v8to a version that resolves this vulnerability.Fixed in 8.0.0-20250929212932-a41db04d2746 - Upgrade
Upgrade
go/github.com/mattermost/mattermost-serverto a version that resolves this vulnerability.Fixed in 10.12.1 - Upgrade
Upgrade
go/github.com/mattermost/mattermost-serverto a version that resolves this vulnerability.Fixed in 10.5.12 - Upgrade
Upgrade
go/github.com/mattermost/mattermost-serverto a version that resolves this vulnerability.Fixed in 10.11.4 - Upgrade
Upgrade
Mattermostto a version that resolves this vulnerability.Fixed in 11.0.0
Event History
Frequently Asked Questions
What is the severity of CVE-2025-55073?
CVE-2025-55073 has a critical severity level due to the potential for arbitrary post modification.
How do I fix CVE-2025-55073?
To fix CVE-2025-55073, update Mattermost to versions 10.11.4 or later, 10.5.12 or later, or 10.12.1 or later.
What components are affected by CVE-2025-55073?
CVE-2025-55073 affects Mattermost versions 10.11.x up to 10.11.3, 10.5.x up to 10.5.11, and 10.12.x up to 10.12.0.
Can an attacker exploit CVE-2025-55073 remotely?
Yes, an attacker can remotely exploit CVE-2025-55073 using a crafted MSTeams plugin OAuth redirect URL.
What is the impact of CVE-2025-55073 on Mattermost users?
The impact of CVE-2025-55073 allows attackers to edit any arbitrary posts within the Mattermost application.