CVE-2025-56537: XSS
A stored cross-site scripting (XSS) vulnerability in opennebula v6.10.0.1 and fixed in v.7.0 allows attackers to execute arbitrary web scripts or HTML via injecting a crafted payload into the virtual network template parameter.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
opennebulato a version that resolves this vulnerability.Fixed in 7.0
Event History
Frequently Asked Questions
What is the severity of CVE-2025-56537?
The severity of CVE-2025-56537 is rated as medium with a score of 6.1.
How do I fix CVE-2025-56537?
To fix CVE-2025-56537, upgrade OpenNebula to version 7.0 or later.
What type of vulnerability is CVE-2025-56537?
CVE-2025-56537 is a stored cross-site scripting (XSS) vulnerability.
Which versions of OpenNebula are affected by CVE-2025-56537?
OpenNebula versions v6.10.0.1 and earlier are affected by CVE-2025-56537.
What can attackers do with CVE-2025-56537?
Attackers can execute arbitrary web scripts or HTML by injecting a crafted payload into the virtual network template parameter.