CVE-2025-58230: WordPress ZoloBlocks plugin <= 2.3.12 - Cross Site Scripting (XSS) vulnerability
Published Sep 22, 2025
·Updated
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bdthemes ZoloBlocks zoloblocks allows DOM-Based XSS.This issue affects ZoloBlocks: from n/a through <= 2.3.12.
Affected Software
1 affected component
BdThemes ZoloBlocks<=2.3.12
Event History
Sep 22, 2025
CVE Published
via MITRE·06:23 PM
Data Sourced
via MITRE·06:23 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·07:16 PM
DescriptionSeverityWeakness
Frequently Asked Questions
1
What is the severity of CVE-2025-58230?
The severity of CVE-2025-58230 is considered high due to the potential for DOM-Based Cross-Site Scripting (XSS) attacks.
2
How do I fix CVE-2025-58230?
To fix CVE-2025-58230, update the ZoloBlocks plugin to version 2.3.10 or later.
3
What is the impact of CVE-2025-58230 on my website?
CVE-2025-58230 can allow attackers to execute malicious scripts on your website, potentially compromising user data.
4
Which software versions are affected by CVE-2025-58230?
CVE-2025-58230 affects ZoloBlocks versions up to and including 2.3.9.
5
Is CVE-2025-58230 related to other vulnerabilities?
CVE-2025-58230 is specifically related to improper input neutralization in ZoloBlocks, which can lead to cross-site scripting vulnerabilities.