CVE-2025-59464: Memory leak that enables remote Denial of Service against applications processing TLS client certificates

Published Jan 13, 2026
·
Updated

A memory leak in Node.js’s OpenSSL integration occurs when converting X.509 certificate fields to UTF-8 without freeing the allocated buffer. When applications call socket.getPeerCertificate(true), each certificate field leaks memory, allowing remote clients to trigger steady memory growth through repeated TLS connections. Over time this can lead to resource exhaustion and denial of service.

Other sources

A memory leak in Node.js’s OpenSSL integration occurs when converting X.509 certificate fields to UTF-8 without freeing the allocated buffer. When applications call socket.getPeerCertificate(true), each certificate field leaks memory, allowing remote clients to trigger steady memory growth through repeated TLS connections. Over time this can lead to resource exhaustion and denial of service.

This vulnerability was already fixed on Node.js 24.12.0. It has no impact on other active release lines.

— Node.Js

Affected Software

4 affected componentsFixes available
Node.js Node.js
Nodejs Node.js>=24.0.0<24.12.0
Node.js Node.js>=20.0.0<20.20.0, >=22.0.0<22.22.0, >=24.0.0<24.13.0
20.20.022.22.024.13.0
Node.js Node.js>=24.0.0<24.13.0
24.13.0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 20.20.0Fixed in 22.22.0Fixed in 24.13.0
  2. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 24.13.0
  3. Upgrade

    Upgrade Node.js to a version that resolves this vulnerability.

    Fixed in 24.12.0

Event History

Jan 13, 2026
CVE Published
via Node.js·12:00 AM
Data Sourced
via Node.js·12:00 AM
DescriptionSeverityAffected Software
Jan 20, 2026
CVE Published
via MITRE·08:41 PM
Data Sourced
via MITRE·08:41 PM
DescriptionSeverity
Data Sourced
via NVD·09:16 PM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2025-59464?

CVE-2025-59464 has a medium severity rating due to the potential for remote clients to cause memory leaks.

2

How do I fix CVE-2025-59464?

To fix CVE-2025-59464, it is recommended to update to the latest version of Node.js that addresses the memory leak in the OpenSSL integration.

3

What versions of Node.js are affected by CVE-2025-59464?

CVE-2025-59464 affects multiple versions of Node.js that utilize the OpenSSL integration for handling X.509 certificate fields.

4

Can CVE-2025-59464 affect application performance?

Yes, CVE-2025-59464 can lead to steady memory growth, which may degrade application performance over time.

5

Is there a workaround for CVE-2025-59464?

Currently, there are no known workarounds for CVE-2025-59464 other than upgrading to a patched version of Node.js.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203