CVE-2025-61733: Apache Kylin: Authentication bypass
Authentication Bypass Using an Alternate Path or Channel vulnerability in Apache Kylin.
This issue affects Apache Kylin: from 4.0.0 through 5.0.2.
Users are recommended to upgrade to version 5.0.3, which fixes the issue.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
maven/org.apache.kylin:kylin-core-commonto a version that resolves this vulnerability.Fixed in 5.0.3 - Upgrade
Upgrade
maven/org.apache.kylin:kylinto a version that resolves this vulnerability.Fixed in 5.0.3 - Upgrade
Upgrade
Apache Kylinto a version that resolves this vulnerability.Fixed in 5.0.3
Event History
Frequently Asked Questions
What is the severity of CVE-2025-61733?
CVE-2025-61733 has been classified as a security vulnerability that allows for authentication bypass.
How do I fix CVE-2025-61733?
To fix CVE-2025-61733, users should upgrade Apache Kylin to version 5.0.3 or later.
Which versions of Apache Kylin are affected by CVE-2025-61733?
CVE-2025-61733 affects Apache Kylin versions from 4.0.0 through 5.0.2.
What type of vulnerability is CVE-2025-61733?
CVE-2025-61733 is classified as an authentication bypass vulnerability.
Who is affected by CVE-2025-61733?
Users running versions of Apache Kylin between 4.0.0 and 5.0.2 are affected by CVE-2025-61733.