CVE-2025-61734: Apache Kylin: improper restriction of file read

Published Sep 30, 2025
·
Updated

Files or Directories Accessible to External Parties vulnerability in Apache Kylin. You are fine as long as the Kylin's system and project admin access is well protected.

This issue affects Apache Kylin: from 4.0.0 through 5.0.2.

Users are recommended to upgrade to version 5.0.3, which fixes the issue.

Affected Software

9 affected componentsFixes available
Apache Kylin>=4.0.0<5.0.2
maven/org.apache.kylin:kylin-server>=4.0.0<5.0.3
5.0.3
maven/org.apache.kylin:kylin-ops-server>=4.0.0<5.0.3
5.0.3
maven/org.apache.kylin:kylin-core-metadata>=4.0.0<5.0.3
5.0.3
maven/org.apache.kylin:kylin-core-common>=4.0.0<5.0.3
5.0.3
maven/org.apache.kylin:kylin-common-service>=4.0.0<5.0.3
5.0.3
maven/org.apache.kylin:kylin-common-server>=4.0.0<5.0.3
5.0.3
maven/org.apache.kylin:kylin>=4.0.0<5.0.3
5.0.3
Apache Kylin>=4.0.0<5.0.3

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade maven/org.apache.kylin:kylin-server to a version that resolves this vulnerability.

    Fixed in 5.0.3
  2. Upgrade

    Upgrade maven/org.apache.kylin:kylin-ops-server to a version that resolves this vulnerability.

    Fixed in 5.0.3
  3. Upgrade

    Upgrade maven/org.apache.kylin:kylin-core-metadata to a version that resolves this vulnerability.

    Fixed in 5.0.3
  4. Upgrade

    Upgrade maven/org.apache.kylin:kylin-core-common to a version that resolves this vulnerability.

    Fixed in 5.0.3
  5. Upgrade

    Upgrade maven/org.apache.kylin:kylin-common-service to a version that resolves this vulnerability.

    Fixed in 5.0.3
  6. Upgrade

    Upgrade maven/org.apache.kylin:kylin-common-server to a version that resolves this vulnerability.

    Fixed in 5.0.3
  7. Upgrade

    Upgrade maven/org.apache.kylin:kylin to a version that resolves this vulnerability.

    Fixed in 5.0.3
  8. Upgrade

    Upgrade Apache Kylin to a version that resolves this vulnerability.

    Fixed in 5.0.3
  9. Compensating control

    Protect Kylin system and project administrator access.

Event History

Oct 2, 2025
CVE Published
via MITRE·09:47 AM
Data Sourced
via MITRE·09:47 AM
DescriptionWeakness
Data Sourced
via NVD·10:15 AM
DescriptionSeverityWeaknessAffected Software
Advisory Published
via GitHub·12:31 PM
Data Sourced
via GitHub·12:31 PM
DescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2025-61734?

CVE-2025-61734 is considered a high-severity vulnerability due to the risk of files or directories being accessible to external parties.

2

How do I fix CVE-2025-61734?

To fix CVE-2025-61734, upgrade Apache Kylin to version 5.0.3 or later.

3

Which versions of Apache Kylin are affected by CVE-2025-61734?

CVE-2025-61734 affects Apache Kylin versions from 4.0.0 through 5.0.2.

4

What type of vulnerability is CVE-2025-61734?

CVE-2025-61734 is a files or directories accessible to external parties vulnerability.

5

Is there a recommended action for system admins regarding CVE-2025-61734?

System and project admin access should be well protected to mitigate the risks associated with CVE-2025-61734.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203