CVE-2025-61735: Apache Kylin: Server-Side Request Forgery

Published Sep 30, 2025
·
Updated

Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin.

This issue affects Apache Kylin: from 4.0.0 through 5.0.2. You are fine as long as the Kylin's system and project admin access is well protected.

Users are recommended to upgrade to version 5.0.3, which fixes the issue.

Affected Software

9 affected componentsFixes available
Apache Kylin>=4.0.0<=5.0.2
maven/org.apache.kylin:kylin-server>=4.0.0<5.0.3
5.0.3
maven/org.apache.kylin:kylin-ops-server>=4.0.0<5.0.3
5.0.3
maven/org.apache.kylin:kylin-core-metadata>=4.0.0<5.0.3
5.0.3
maven/org.apache.kylin:kylin-core-common>=4.0.0<5.0.3
5.0.3
maven/org.apache.kylin:kylin-common-service>=4.0.0<5.0.3
5.0.3
maven/org.apache.kylin:kylin-common-server>=4.0.0<5.0.3
5.0.3
maven/org.apache.kylin:kylin>=4.0.0<5.0.3
5.0.3
Apache Kylin>=4.0.0<5.0.3

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade maven/org.apache.kylin:kylin-server to a version that resolves this vulnerability.

    Fixed in 5.0.3
  2. Upgrade

    Upgrade maven/org.apache.kylin:kylin-ops-server to a version that resolves this vulnerability.

    Fixed in 5.0.3
  3. Upgrade

    Upgrade maven/org.apache.kylin:kylin-core-metadata to a version that resolves this vulnerability.

    Fixed in 5.0.3
  4. Upgrade

    Upgrade maven/org.apache.kylin:kylin-core-common to a version that resolves this vulnerability.

    Fixed in 5.0.3
  5. Upgrade

    Upgrade maven/org.apache.kylin:kylin-common-service to a version that resolves this vulnerability.

    Fixed in 5.0.3
  6. Upgrade

    Upgrade maven/org.apache.kylin:kylin-common-server to a version that resolves this vulnerability.

    Fixed in 5.0.3
  7. Upgrade

    Upgrade maven/org.apache.kylin:kylin to a version that resolves this vulnerability.

    Fixed in 5.0.3
  8. Upgrade

    Upgrade Apache Kylin to a version that resolves this vulnerability.

    Fixed in 5.0.3
  9. Compensating control

    Protect Apache Kylin system and project admin access.

Event History

Oct 2, 2025
CVE Published
via MITRE·09:47 AM
Data Sourced
via MITRE·09:47 AM
DescriptionWeakness
Data Sourced
via NVD·10:15 AM
DescriptionSeverityWeaknessAffected Software
Advisory Published
via GitHub·12:31 PM
Data Sourced
via GitHub·12:31 PM
DescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2025-61735?

The severity of CVE-2025-61735 is classified as a moderate vulnerability affecting Apache Kylin versions 4.0.0 to 5.0.2.

2

How do I fix CVE-2025-61735?

To fix CVE-2025-61735, users should upgrade Apache Kylin to version 5.0.3 or later.

3

Which versions of Apache Kylin are affected by CVE-2025-61735?

CVE-2025-61735 affects Apache Kylin from versions 4.0.0 through 5.0.2.

4

What type of vulnerability is CVE-2025-61735?

CVE-2025-61735 is a Server-Side Request Forgery (SSRF) vulnerability.

5

What should I do if I cannot upgrade Apache Kylin to the fixed version for CVE-2025-61735?

If you cannot upgrade, ensure that Kylin's system and project admin access is well protected to mitigate the risk.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203